summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-29 10:04:21 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-29 10:05:08 +0200
commit0ee8df59576601e98af0269aa96a66f2f8b713c6 (patch)
tree9ccd0d209856484a395c17567f2656f9e1095c74 /x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild
parentsys-apps/ripgrep: revbump 12.1.0, fix uncompress .Z support (diff)
downloadgentoo-0ee8df59576601e98af0269aa96a66f2f8b713c6.tar.gz
gentoo-0ee8df59576601e98af0269aa96a66f2f8b713c6.tar.bz2
gentoo-0ee8df59576601e98af0269aa96a66f2f8b713c6.zip
x11-misc/fraqtive: Depend on dev-qt/qtxml:5
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Closes: https://bugs.gentoo.org/726040 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild')
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild b/x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild
new file mode 100644
index 000000000000..7c98c2069002
--- /dev/null
+++ b/x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils toolchain-funcs xdg
+
+DESCRIPTION="Open source, multi-platform generator of the Mandelbrot family fractals"
+HOMEPAGE="https://fraqtive.mimec.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse2"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtxml:5
+ virtual/glu
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-includes.patch" )
+
+src_configure() {
+ tc-export PKG_CONFIG
+ sed -i -e "s|-lGLU|$( ${PKG_CONFIG} --libs glu )|g" src/src.pro || die
+ local conf="release"
+
+ if use cpu_flags_x86_sse2; then
+ conf="$conf sse2"
+ else
+ conf="$conf no-sse2"
+ fi
+
+ echo "CONFIG += $conf" > config.pri
+ echo "PREFIX = ${EPREFIX}/usr" >> config.pri
+ # Don't strip wrt #252096
+ echo "QMAKE_STRIP =" >> config.pri
+
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}