summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/gbdfed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/gbdfed')
-rw-r--r--x11-misc/gbdfed/Manifest2
-rw-r--r--x11-misc/gbdfed/files/gbdfed-1.4-glibc-2.10.patch39
-rw-r--r--x11-misc/gbdfed/gbdfed-1.5.ebuild31
-rw-r--r--x11-misc/gbdfed/gbdfed-1.6.ebuild30
-rw-r--r--x11-misc/gbdfed/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/x11-misc/gbdfed/Manifest b/x11-misc/gbdfed/Manifest
new file mode 100644
index 000000000000..091feca27494
--- /dev/null
+++ b/x11-misc/gbdfed/Manifest
@@ -0,0 +1,2 @@
+DIST gbdfed-1.5.tbz2 229315 RMD160 d3754e4b0a2005ac347010a21296e45e1b1d3ef6 SHA1 b3a937beedf222e10bf6f379240d43687a9c75ac SHA256 d3cd6c3b26b1ed4d0bf8a186d5cc180f1be699864a52899016a31576fb5f65ae
+DIST gbdfed-1.6.tbz2 236166 RMD160 205de4c1e3e2e0e3e3c037d2b1f3090ff15723f0 SHA1 4985f100e56a5b097f169f63be3ef7b054d929c9 SHA256 5db25d4ce688dcb188dee056e58614a94a5e4fce4b6066fbb310951ab999093c
diff --git a/x11-misc/gbdfed/files/gbdfed-1.4-glibc-2.10.patch b/x11-misc/gbdfed/files/gbdfed-1.4-glibc-2.10.patch
new file mode 100644
index 000000000000..5a4f690da70b
--- /dev/null
+++ b/x11-misc/gbdfed/files/gbdfed-1.4-glibc-2.10.patch
@@ -0,0 +1,39 @@
+--- bdfgname.c
++++ bdfgname.c
+@@ -39,7 +39,7 @@
+ #define MAX_GLYPH_NAME_LEN 127
+
+ static int
+-getline(FILE *in, char *buf, int limit)
++bdf_getline(FILE *in, char *buf, int limit)
+ {
+ int c, i;
+
+@@ -78,11 +78,11 @@
+
+ while (!feof(in)) {
+ pos = ftell(in);
+- (void) getline(in, buf, 256);
++ (void) bdf_getline(in, buf, 256);
+ while (!feof(in) && (buf[0] == 0 || buf[0] == '#')) {
+ buf[0] = 0;
+ pos = ftell(in);
+- (void) getline(in, buf, 256);
++ (void) bdf_getline(in, buf, 256);
+ }
+
+ if (buf[0] == 0)
+@@ -139,11 +139,11 @@
+
+ while (!feof(in)) {
+ pos = ftell(in);
+- (void) getline(in, buf, 256);
++ (void) bdf_getline(in, buf, 256);
+ while (!feof(in) && (buf[0] == 0 || buf[0] == '#')) {
+ buf[0] = 0;
+ pos = ftell(in);
+- (void) getline(in, buf, 256);
++ (void) bdf_getline(in, buf, 256);
+ }
+
+ if (adobe_names_used == adobe_names_size) {
diff --git a/x11-misc/gbdfed/gbdfed-1.5.ebuild b/x11-misc/gbdfed/gbdfed-1.5.ebuild
new file mode 100644
index 000000000000..cdd9181017e8
--- /dev/null
+++ b/x11-misc/gbdfed/gbdfed-1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="gbdfed Bitmap Font Editor"
+HOMEPAGE="http://www.math.nmsu.edu/~mleisher/Software/gbdfed/"
+SRC_URI="http://www.math.nmsu.edu/~mleisher/Software/gbdfed/${P}.tbz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=media-libs/freetype-2
+ x11-libs/libX11
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-glibc-2.10.patch
+ sed "s:-D.*_DISABLE_DEPRECATED::" -i Makefile.in #248562
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README NEWS || die
+}
diff --git a/x11-misc/gbdfed/gbdfed-1.6.ebuild b/x11-misc/gbdfed/gbdfed-1.6.ebuild
new file mode 100644
index 000000000000..1ff3a0625fdf
--- /dev/null
+++ b/x11-misc/gbdfed/gbdfed-1.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="gbdfed Bitmap Font Editor"
+HOMEPAGE="http://www.math.nmsu.edu/~mleisher/Software/gbdfed/"
+SRC_URI="http://www.math.nmsu.edu/~mleisher/Software/gbdfed/${P}.tbz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=media-libs/freetype-2
+ x11-libs/libX11
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed "s:-D.*_DISABLE_DEPRECATED::" -i Makefile.in #248562
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS
+}
diff --git a/x11-misc/gbdfed/metadata.xml b/x11-misc/gbdfed/metadata.xml
new file mode 100644
index 000000000000..64cc0b687d48
--- /dev/null
+++ b/x11-misc/gbdfed/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>fonts</herd>
+</pkgmetadata>