summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/gmrun/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/gmrun/files')
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch40
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch11
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch35
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch41
4 files changed, 127 insertions, 0 deletions
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch b/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch
new file mode 100644
index 000000000000..e1d4d6d211ac
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch
@@ -0,0 +1,40 @@
+--- a/src/gtkcompletionline.cc
++++ b/src/gtkcompletionline.cc
+@@ -29,6 +29,7 @@
+ #include <set>
+ #include <sstream>
+ #include <string>
++#include <cstring>
+ #include <vector>
+ using namespace std;
+
+--- a/src/ci_string.h
++++ b/src/ci_string.h
+@@ -7,6 +7,7 @@
+ #define __CI_STRING_H__
+
+ #include <string>
++#include <cstring>
+ #include <ctype.h>
+
+ struct ci_char_traits : public std::char_traits<char>
+--- a/src/prefs.cc
++++ b/src/prefs.cc
+@@ -13,6 +13,7 @@
+ #include <fstream>
+ #include <iostream>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include <list>
+
+--- a/src/main.cc
++++ b/src/main.cc
+@@ -14,6 +14,7 @@
+ #include <gdk/gdkkeysyms.h>
+
+ #include <string>
++#include <cstring>
+ #include <iostream>
+ #include <sstream>
+ #include <vector>
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch b/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
new file mode 100644
index 000000000000..6e12a56f431d
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
@@ -0,0 +1,11 @@
+--- a/src/gtkcompletionline.cc
++++ b/src/gtkcompletionline.cc
+@@ -376,7 +377,7 @@
+ return 0;
+ }
+
+-int my_alphasort(const void* va, const void* vb) {
++int my_alphasort(const dirent** va, const dirent** vb) {
+ const struct dirent** a = (const struct dirent**)va;
+ const struct dirent** b = (const struct dirent**)vb;
+
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch b/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch
new file mode 100644
index 000000000000..426f652a0c2b
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/show_bug.cgi?id=164339
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+ INCLUDES = \
+- @GTK_CFLAGS@ @STLPORT_CXXFLAGS@
++ @GTK_CFLAGS@
+
+ bin_PROGRAMS = gmrun
+
+@@ -13,7 +13,7 @@
+
+ # gmrun_LDFLAGS = -s
+
+-gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
++gmrun_LDADD = @GTK_LIBS@
+
+ AM_CPPFLAGS = \
+ -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
+--- a/configure.in
++++ b/configure.in
+@@ -37,8 +37,8 @@
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+ AC_PROG_CXX
+-AC_PATH_STLPORT_LIB
+-AC_PATH_STLPORT_INC
++dnl REMOVED _LIB
++dnl REMOVED _INC
+
+
+ AC_CHECK_FUNC( poptGetContext,
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
new file mode 100644
index 000000000000..92db743a8df5
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
@@ -0,0 +1,41 @@
+http://bugs.gentoo.org/292856
+
+--- a/config/Makefile.am
++++ b/config/Makefile.am
+@@ -1,6 +1,6 @@
+ # $Id$
+
+-myrcdir = @PACKAGE_DATA_DIR@
++myrcdir = $(sysconfdir)
+ myrc_DATA = gmrunrc
+
+ EXTRA_DIST = gmrunrc
+--- a/config.h.in
++++ b/config.h.in
+@@ -10,7 +10,6 @@
+ #undef HAVE_STPCPY
+ #undef HAVE_LIBSM
+ #undef PACKAGE_LOCALE_DIR
+-#undef PACKAGE_DATA_DIR
+ #undef PACKAGE_SOURCE_DIR
+
+ /* Define if you have the <dirent.h> header file. */
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,3 +15,5 @@
+
+ gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
+
++AM_CPPFLAGS = \
++ -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
+--- a/src/prefs.cc
++++ b/src/prefs.cc
+@@ -30,7 +30,7 @@
+
+ Prefs::Prefs()
+ {
+- string file_name = PACKAGE_DATA_DIR"/";
++ string file_name = PACKAGE_SYSCONF_DIR"/";
+ file_name += GMRUNRC;
+ init(file_name);
+