summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-11 01:22:41 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-11 01:23:15 +0200
commit926eef459172d839e157412df307229d7fc5c12c (patch)
tree805484e8b0cbf2c1a370206aab1e62935f2883ba /x11-misc/gpaste/gpaste-3.16.2.1.ebuild
parentx11-misc/gpaste: initial import of version 3.14 (diff)
downloadgentoo-926eef459172d839e157412df307229d7fc5c12c.tar.gz
gentoo-926eef459172d839e157412df307229d7fc5c12c.tar.bz2
gentoo-926eef459172d839e157412df307229d7fc5c12c.zip
x11-misc/gpaste: version bump to 3.16.2.1
This is totally untested, added with lots of good faith, since I don't want to update my glib just yet.
Diffstat (limited to 'x11-misc/gpaste/gpaste-3.16.2.1.ebuild')
-rw-r--r--x11-misc/gpaste/gpaste-3.16.2.1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/gpaste/gpaste-3.16.2.1.ebuild b/x11-misc/gpaste/gpaste-3.16.2.1.ebuild
new file mode 100644
index 000000000000..47b2d4f6ae86
--- /dev/null
+++ b/x11-misc/gpaste/gpaste-3.16.2.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils autotools gnome2-utils vala vcs-snapshot
+
+DESCRIPTION="Clipboard management system"
+HOMEPAGE="https://github.com/Keruspe/GPaste"
+SRC_URI="https://github.com/Keruspe/GPaste/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+applet gnome vala"
+
+CDEPEND="
+ dev-util/appdata-tools
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/gobject-introspection-1.44.0
+ sys-apps/dbus
+ >=x11-libs/gdk-pixbuf-2.26:2
+ >=x11-libs/gtk+-3.16:3
+ x11-libs/libX11
+ x11-libs/libXi
+ gnome? (
+ gnome-base/gnome-control-center:2
+ media-libs/clutter
+ x11-libs/pango
+ )
+"
+RDEPEND="${CDEPEND}
+ gnome? (
+ gnome-base/gnome-shell
+ )
+"
+DEPEND="${CDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ eautoreconf
+ intltoolize --force --automake || die "intltoolize error"
+ vala_src_prepare
+
+ if ! use gnome ; then
+ echo "" > data/control-center.mk || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable vala) \
+ $(use_enable applet) \
+ --disable-unity \
+ $(use_enable gnome gnome-shell-extension) \
+ --disable-static \
+ --disable-schemas-compile
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}