summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesse Harris <zigford@gmail.com>2020-09-12 15:58:44 +1000
committerJoonas Niilola <juippis@gentoo.org>2020-09-27 13:27:26 +0300
commit4f76682516c82d0db0c93a2e5d9cc128fdbf191d (patch)
tree48c0984e7a1f903829f313a3af13b71d6399e46f /x11-misc/gpaste
parentapp-accessibility/speech-tools: fixed calling ar and ranlib in 2.5.0 (diff)
downloadgentoo-4f76682516c82d0db0c93a2e5d9cc128fdbf191d.tar.gz
gentoo-4f76682516c82d0db0c93a2e5d9cc128fdbf191d.tar.bz2
gentoo-4f76682516c82d0db0c93a2e5d9cc128fdbf191d.zip
x11-misc/gpaste: bump to 3.36
Signed-off-by: Jesse Harris <zigford@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17505 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/gpaste')
-rw-r--r--x11-misc/gpaste/Manifest1
-rw-r--r--x11-misc/gpaste/gpaste-3.36.3.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/x11-misc/gpaste/Manifest b/x11-misc/gpaste/Manifest
index 2cabf769016e..4a12fc415f35 100644
--- a/x11-misc/gpaste/Manifest
+++ b/x11-misc/gpaste/Manifest
@@ -1 +1,2 @@
DIST gpaste-3.20.3.tar.gz 157869 BLAKE2B 02b52b8023c875bd3c651cc5864603812f0cfd49cfac774ee4e27eae63c66e46f34d5128b717af514cc1c57fb93a775ff01f827210bd7cfa5e9ab5de9a87fd07 SHA512 08b7c52d16e630ac57e4d583ae985763b536728ef9997ce5ecc8a8ffb9be8745e1e5aed9003a4ab522ba76a276855c6a095fef7a73b4f4d80b54c7a9c3e6e9d1
+DIST gpaste-3.36.3.tar.gz 186352 BLAKE2B b00af3f32076bbeb4f06853a7892772901d0c72dd972d08fff0520afae388bed0c9eee81892a2492f4bb972b3a80a924519e1c137edb660fa5f9dfa2fab31856 SHA512 e5fe4a31367e96089aefd1af5ed0a3ad591eee009bbc74b1b33c9c736061831979d79f2d6a5c072cf55fc6f1982ade581fe73d2039c5dbd607081683860c7b9f
diff --git a/x11-misc/gpaste/gpaste-3.36.3.ebuild b/x11-misc/gpaste/gpaste-3.36.3.ebuild
new file mode 100644
index 000000000000..ed725004116e
--- /dev/null
+++ b/x11-misc/gpaste/gpaste-3.36.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION="0.30"
+VALA_USE_DEPEND="vapigen"
+
+inherit meson vala gnome2-utils
+
+DESCRIPTION="Clipboard management system"
+HOMEPAGE="https://github.com/Keruspe/GPaste"
+SRC_URI="https://github.com/Keruspe/GPaste/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +gnome vala systemd"
+REQUIRED_USE="
+ vala? ( introspection )
+ gnome? ( introspection )
+"
+
+DEPEND="
+ x11-libs/pango
+ dev-libs/appstream-glib
+ >=dev-libs/glib-2.48:2
+ introspection? (
+ >=x11-wm/mutter-3.36[introspection]
+ dev-libs/gjs
+ >=dev-libs/gobject-introspection-1.48.0
+ )
+ sys-apps/dbus
+ >=x11-libs/gdk-pixbuf-2.34:2
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ x11-libs/libXi
+ gnome? (
+ >=x11-wm/mutter-3.36
+ )
+"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ gnome? (
+ gnome-base/gnome-control-center:2
+ )
+ virtual/pkgconfig
+ systemd? (
+ sys-apps/systemd
+ )
+"
+RDEPEND="${DEPEND}
+ gnome? (
+ gnome-base/gnome-control-center:2
+ gnome-base/gnome-shell
+ )
+ systemd? (
+ sys-apps/systemd
+ )
+"
+
+S=${WORKDIR}/GPaste-${PV}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use systemd systemd)
+ -Dbash-completion=true
+ -Dzsh-completion=true
+ -Dx-keybinder=true
+ -Dcontrol-center-keybindings-dir=$(usex gnome '' \
+ '/usr/share/gnome-control-center/keybindings')
+ $(meson_use introspection introspection)
+ $(meson_use vala vapi)
+ $(meson_use gnome gnome-shell)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}