summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/grabc/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/grabc/files')
-rw-r--r--x11-misc/grabc/files/grabc-1.1-makefile.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/grabc/files/grabc-1.1-makefile.patch b/x11-misc/grabc/files/grabc-1.1-makefile.patch
new file mode 100644
index 000000000000..4815ae5675c5
--- /dev/null
+++ b/x11-misc/grabc/files/grabc-1.1-makefile.patch
@@ -0,0 +1,37 @@
+--- grabc1.1/Makefile.org 1997-03-17 06:51:39.000000000 +0100
++++ grabc1.1/Makefile 2010-02-08 12:18:34.000000000 +0100
+@@ -2,17 +2,15 @@
+ # Makefile automatically generated by genmake 1.0, Mar-16-97
+ # genmake 1.0 by ma_muquit@fccc.edu, RCS
+ ##
+-CC= cc
+ DEFS=
+ PROGNAME= grabc
+-LIBS= -L/usr/X11R6/lib -lX11
++LIBS= $(shell pkg-config --libs x11)
+
+ INCLUDES= -I.
+
+-# replace -O with -g in order to debug
++# replace -O2 -pipe -Wall -march=athlon-xp with -g in order to debug
+
+ DEFINES= $(INCLUDES) $(DEFS) -D__USE_FIXED_PROTOTYPES__ -DSYS_UNIX=1
+-CFLAGS= -O $(DEFINES)
+
+ SRCS = grabc.c
+
+@@ -20,12 +18,12 @@
+
+ .c.o:
+ rm -f $@
+- $(CC) $(CFLAGS) -c $*.c
++ $(CC) $(CFLAGS) $(DEFINES) -c $*.c
+
+ all: $(PROGNAME)
+
+ $(PROGNAME) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(PROGNAME) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(PROGNAME) $(OBJS) $(LIBS)
+
+ clean:
+ rm -f $(OBJS) $(PROGNAME) core