summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-18 21:04:28 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-18 21:05:35 +0100
commitac1c61e66cfae101b753f0012ddd9aca0b792a67 (patch)
tree6cab9f5dd5ef623cc513d26915c4d7f300fd1b98 /x11-misc/gromit/files
parentsec-policy/selinux-base: add arm/arm64/mips love (diff)
downloadgentoo-ac1c61e66cfae101b753f0012ddd9aca0b792a67.tar.gz
gentoo-ac1c61e66cfae101b753f0012ddd9aca0b792a67.tar.bz2
gentoo-ac1c61e66cfae101b753f0012ddd9aca0b792a67.zip
x11-misc/gromit: Fix build issues (#369453 by kensington, #552574)
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-misc/gromit/files')
-rw-r--r--x11-misc/gromit/files/gromit-20041213-build.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11-misc/gromit/files/gromit-20041213-build.patch b/x11-misc/gromit/files/gromit-20041213-build.patch
new file mode 100644
index 000000000000..f61a13bcccd6
--- /dev/null
+++ b/x11-misc/gromit/files/gromit-20041213-build.patch
@@ -0,0 +1,19 @@
+Respect CC, CFLAGS, & LDFLAGS.
+Drop DEPRECATED flags for bug #387833.
+Fix underlinking for bug #369453.
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,10 @@
+ all: gromit
+
+ proptest: proptest.c
+- gcc -o proptest proptest.c `gtk-config --libs --cflags`
++ $(CC) -o proptest proptest.c `gtk-config --libs --cflags`
+
+ propertywatch: propertywatch.c
+- gcc -o propertywatch propertywatch.c `gtk-config --libs --cflags`
++ $(CC) -o propertywatch propertywatch.c `gtk-config --libs --cflags`
+
+ gromit: gromit.c Makefile
+- gcc -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall `pkg-config --libs --cflags gtk+-2.0`
++ $(CC) -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall $(CFLAGS) $(LDFLAGS) `pkg-config --libs --cflags gtk+-2.0` -lX11 -lm