summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-25 09:22:18 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-25 09:22:18 +0100
commit6cd89a387ac11c1dcbc758a1d07011fd4236f709 (patch)
treeae01e387318708b933f1d6f1838d81ae965f4218 /x11-misc/i3lock/i3lock-2.10.ebuild
parentsci-geosciences/qmapshack: bump to 1.9.1 (diff)
downloadgentoo-6cd89a387ac11c1dcbc758a1d07011fd4236f709.tar.gz
gentoo-6cd89a387ac11c1dcbc758a1d07011fd4236f709.tar.bz2
gentoo-6cd89a387ac11c1dcbc758a1d07011fd4236f709.zip
x11-misc/i3lock: Version bump.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'x11-misc/i3lock/i3lock-2.10.ebuild')
-rw-r--r--x11-misc/i3lock/i3lock-2.10.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/i3lock/i3lock-2.10.ebuild b/x11-misc/i3lock/i3lock-2.10.ebuild
new file mode 100644
index 000000000000..f99aa9820244
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="http://i3wm.org/i3lock/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/libxkbcommon-0.5.0[X]
+ dev-libs/libev
+ virtual/pam
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+DOCS=( CHANGELOG README.md )
+
+src_prepare() {
+ default
+
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+
+ tc-export CC
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}