summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-04 15:54:35 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-04 15:54:35 +0200
commit49226474fa86142b7dfb587d72071e390a6d73fe (patch)
treea7a750be6e5f5472f083fc10971d57059a653d2b /x11-misc/imake/imake-1.0.8.ebuild
parentx11-misc/vnc2swf: Pass AR to build system (diff)
downloadgentoo-49226474fa86142b7dfb587d72071e390a6d73fe.tar.gz
gentoo-49226474fa86142b7dfb587d72071e390a6d73fe.tar.bz2
gentoo-49226474fa86142b7dfb587d72071e390a6d73fe.zip
x11-misc/imake: Pass CPP explicitly
Closes: https://bugs.gentoo.org/722046 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/imake/imake-1.0.8.ebuild')
-rw-r--r--x11-misc/imake/imake-1.0.8.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11-misc/imake/imake-1.0.8.ebuild b/x11-misc/imake/imake-1.0.8.ebuild
index 4e2c15dde421..4ace6394603e 100644
--- a/x11-misc/imake/imake-1.0.8.ebuild
+++ b/x11-misc/imake/imake-1.0.8.ebuild
@@ -4,7 +4,7 @@
EAPI=7
XORG_STATIC=no
-inherit xorg-3
+inherit toolchain-funcs xorg-3
DESCRIPTION="C preprocessor interface to the make utility"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
@@ -13,3 +13,7 @@ IUSE=""
RDEPEND="x11-misc/xorg-cf-files"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+
+src_configure() {
+ econf CPP="$(tc-getPROG CPP cpp)"
+}