summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/kbdd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/kbdd')
-rw-r--r--x11-misc/kbdd/Manifest2
-rw-r--r--x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch16
-rw-r--r--x11-misc/kbdd/kbdd-0.5.2.ebuild36
-rw-r--r--x11-misc/kbdd/kbdd-0.7.ebuild37
-rw-r--r--x11-misc/kbdd/metadata.xml11
5 files changed, 102 insertions, 0 deletions
diff --git a/x11-misc/kbdd/Manifest b/x11-misc/kbdd/Manifest
new file mode 100644
index 000000000000..5ab00ecf21f8
--- /dev/null
+++ b/x11-misc/kbdd/Manifest
@@ -0,0 +1,2 @@
+DIST kbdd-0.5.2.tar.gz 30680 SHA256 fb49d09d8b9e4605ed6028eb37acbb404807dffb09cf8e4ee529abcda9b5e7c6 SHA512 dc911ea9a7c97a986a8f8bfd3936d2ea4a691e3d6aacfb606821b7a458b84011ee6e4dba60ae2cd105fe599b41a8d28e3f0345f0865150005e042c92796bb6e3 WHIRLPOOL 3c2b8017c3931e30fb4444433732901fb0cf5f2f21540bbe889a6e8ea8a1fc8f2e8d7a1f9f6511fac5adc4a07a6b996accff142b3f08bb52f2edc094bcb2378b
+DIST kbdd-0.7.tar.gz 32550 SHA256 325231d4491bfbdb80ce66c1b4db3c41081d915f1c2af8cfc1d68590c640b489 SHA512 959c07746207819b6c2ba74635d737767970ccd9442b728021c8162de01f08a709aced78473ddd942d46159264b89e631ef35a0cd9c5330f71710a55125aeaa0 WHIRLPOOL f16bdbdd21fb8188bc46c044693510610573486cfa058957293a1dcaa7b6a2294735bda859d50fb8297072676ae25bc1cb58282652a5db12410cf389c91407c8
diff --git a/x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch b/x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch
new file mode 100644
index 000000000000..4bb3bb7feeca
--- /dev/null
+++ b/x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch
@@ -0,0 +1,16 @@
+diff --git a/src/kbdd.c b/src/kbdd.c
+index 45968be..9402725 100644
+--- a/src/kbdd.c
++++ b/src/kbdd.c
+@@ -31,9 +31,10 @@
+ #include "config.h"
+ #endif
+
++#include <glib.h>
++
+ #ifdef ENABLE_DBUS
+ #include <pthread.h>
+-#include <glib.h>
+ #include "dbus/m-kbdd-service.h"
+ #include "dbus/kbdd-service-glue.h"
+ #endif
diff --git a/x11-misc/kbdd/kbdd-0.5.2.ebuild b/x11-misc/kbdd/kbdd-0.5.2.ebuild
new file mode 100644
index 000000000000..7c4536b86c65
--- /dev/null
+++ b/x11-misc/kbdd/kbdd-0.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Very simple layout switcher"
+HOMEPAGE="http://github.com/qnikst/kbdd"
+SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="dev-libs/glib
+ x11-libs/libX11
+ dbus? (
+ sys-apps/dbus
+ >=dev-libs/dbus-glib-0.86
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cd "${WORKDIR}"/qnikst-kbdd-*
+ S=$(pwd)
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable dbus) || die "econf failed"
+}
diff --git a/x11-misc/kbdd/kbdd-0.7.ebuild b/x11-misc/kbdd/kbdd-0.7.ebuild
new file mode 100644
index 000000000000..cd9fa2a32141
--- /dev/null
+++ b/x11-misc/kbdd/kbdd-0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Very simple layout switcher"
+HOMEPAGE="http://github.com/qnikst/kbdd"
+SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="dev-libs/glib
+ x11-libs/libX11
+ dbus? (
+ sys-apps/dbus
+ >=dev-libs/dbus-glib-0.86
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cd "${WORKDIR}"/qnikst-kbdd-*
+ epatch "${FILESDIR}"/kbdd-0.7-fix-non-dbus-build.patch
+ S=$(pwd)
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable dbus) || die "econf failed"
+}
diff --git a/x11-misc/kbdd/metadata.xml b/x11-misc/kbdd/metadata.xml
new file mode 100644
index 000000000000..b700c6b0f22b
--- /dev/null
+++ b/x11-misc/kbdd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>qnikst@gentoo.org</email>
+ <description>Very simple layout switcher</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">qnikst/kbdd</remote-id>
+ </upstream>
+</pkgmetadata>