summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-09-02 18:57:39 +0300
committerMichał Górny <mgorny@gentoo.org>2018-10-07 11:10:17 +0200
commit4b5fdf0db2719feff78f20f09244895cdc52071e (patch)
tree8fde504d4d56ccf9bd6425115aa007e64fdbb3b5 /x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild
parentx11-misc/libinput-gestures: drop old ebuilds (diff)
downloadgentoo-4b5fdf0db2719feff78f20f09244895cdc52071e.tar.gz
gentoo-4b5fdf0db2719feff78f20f09244895cdc52071e.tar.bz2
gentoo-4b5fdf0db2719feff78f20f09244895cdc52071e.zip
x11-misc/libinput-gestures: version bump to 2.38, fix license
1. Fix license. 2. Remove test phase. 3. PYTHON_COMPAT for 3.7 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9766
Diffstat (limited to 'x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild')
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild
new file mode 100644
index 000000000000..87acd6131454
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4..7} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+ SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/libinput-1.8.0
+ x11-misc/xdotool
+ x11-misc/wmctrl"
+DEPEND=">=dev-libs/libinput-1.8.0
+ dev-util/desktop-file-utils"
+
+src_prepare() {
+ default
+
+ # Fix docdir installation path
+ sed '/^DOCDIR/s@$NAME@${PF}@' -i libinput-gestures-setup || die
+}
+
+src_test() { :; }
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "You must be in the input group to read the touchpad device."
+
+ if ! has_version x11-libs/gtk+:3 ; then
+ elog "${PN}-setup script supports Gnome 3 via x11-libs/gtk+:3."
+ fi
+ if ! has_version kde-plasma/kde-cli-tools:5 ; then
+ elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}