summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/lightdm/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/lightdm/files')
-rw-r--r--x11-misc/lightdm/files/README.gentoo11
-rw-r--r--x11-misc/lightdm/files/Xsession74
-rw-r--r--x11-misc/lightdm/files/lightdm8
-rw-r--r--x11-misc/lightdm/files/lightdm-1.2.0-fix-configure.patch10
-rw-r--r--x11-misc/lightdm/files/lightdm-1.7.7-session-wrapper.patch13
-rw-r--r--x11-misc/lightdm/files/lightdm-autologin6
-rw-r--r--x11-misc/lightdm/files/lightdm.service14
-rw-r--r--x11-misc/lightdm/files/session-wrapper-lightdm.patch13
8 files changed, 149 insertions, 0 deletions
diff --git a/x11-misc/lightdm/files/README.gentoo b/x11-misc/lightdm/files/README.gentoo
new file mode 100644
index 000000000000..182f53087548
--- /dev/null
+++ b/x11-misc/lightdm/files/README.gentoo
@@ -0,0 +1,11 @@
+
+ * Even though the default /etc/lightdm/lightdm.conf will work for
+ * most users, make sure you configure it to suit your needs
+ * before using lightdm for the first time.
+ * You can test the configuration file using the following
+ * command: lightdm --test-mode -c /etc/lightdm/lightdm.conf. This
+ * requires xorg-server to be built with the 'kdrive' useflag.
+ *
+ * You can also set your own default values for LIGHTDM_GREETER,
+ * LIGHTDM_SESSION, and LIGHTDM_USER in /etc/portage/make.conf
+
diff --git a/x11-misc/lightdm/files/Xsession b/x11-misc/lightdm/files/Xsession
new file mode 100644
index 000000000000..50ce80fd3e19
--- /dev/null
+++ b/x11-misc/lightdm/files/Xsession
@@ -0,0 +1,74 @@
+#!/bin/sh
+#
+# LightDM wrapper to run around X sessions.
+
+echo "Running X session wrapper"
+
+# Load profile
+for file in "/etc/profile" "$HOME/.profile" "/etc/xprofile" "$HOME/.xprofile"; do
+ if [ -f "$file" ]; then
+ echo "Loading profile from $file";
+ . "$file"
+ fi
+done
+
+# Load resources
+for file in "/etc/X11/Xresources" "$HOME/.Xresources"; do
+ if [ -f "$file" ]; then
+ echo "Loading resource: $file"
+ xrdb -nocpp -merge "$file"
+ fi
+done
+
+# Load keymaps
+for file in "/etc/X11/Xkbmap" "$HOME/.Xkbmap"; do
+ if [ -f "$file" ]; then
+ echo "Loading keymap: $file"
+ setxkbmap `cat "$file"`
+ XKB_IN_USE=yes
+ fi
+done
+
+# Load xmodmap if not using XKB
+if [ -z "$XKB_IN_USE" ]; then
+ for file in "/etc/X11/Xmodmap" "$HOME/.Xmodmap"; do
+ if [ -f "$file" ]; then
+ echo "Loading modmap: $file"
+ xmodmap "$file"
+ fi
+ done
+fi
+
+unset XKB_IN_USE
+
+# /etc/X11/xinit/xinitrc.d/80-dbus expects $command to be
+# set to the Xsession arguments. So make it happy. See
+# https://bugs.gentoo.org/show_bug.cgi?id=533456
+command="$@"
+
+# Run all system xinitrc shell scripts.
+xinitdir="/etc/X11/xinit/xinitrc.d"
+if [ -d "$xinitdir" ]; then
+ for script in $xinitdir/*; do
+ echo "Loading xinit script $script"
+ if [ -x "$script" -a ! -d "$script" ]; then
+ . "$script"
+ fi
+ done
+fi
+
+# Load Xsession scripts
+xsessionddir="/etc/X11/Xsession.d"
+if [ -d "$xsessionddir" ]; then
+ for i in `ls $xsessionddir`; do
+ script="$xsessionddir/$i"
+ echo "Loading X session script $script"
+ if [ -r "$script" -a -f "$script" ] && expr "$i" : '^[[:alnum:]_-]\+$' > /dev/null; then
+ . "$script"
+ fi
+ done
+fi
+
+echo "X session wrapper complete, running session $@"
+
+exec $command
diff --git a/x11-misc/lightdm/files/lightdm b/x11-misc/lightdm/files/lightdm
new file mode 100644
index 000000000000..6286d6ab4f66
--- /dev/null
+++ b/x11-misc/lightdm/files/lightdm
@@ -0,0 +1,8 @@
+#%PAM-1.0
+auth optional pam_env.so
+auth include system-login
+auth required pam_nologin.so
+account include system-login
+password include system-login
+session optional pam_loginuid.so
+session include system-auth
diff --git a/x11-misc/lightdm/files/lightdm-1.2.0-fix-configure.patch b/x11-misc/lightdm/files/lightdm-1.2.0-fix-configure.patch
new file mode 100644
index 000000000000..c8c795e044e1
--- /dev/null
+++ b/x11-misc/lightdm/files/lightdm-1.2.0-fix-configure.patch
@@ -0,0 +1,10 @@
+--- configure.ac~ 2012-04-23 12:12:44.000000000 +0100
++++ configure.ac 2012-04-23 12:25:51.050999668 +0100
+@@ -93,6 +93,7 @@
+ PKG_CHECK_MODULES(LIBLIGHTDM_QT, [
+ QtCore
+ QtDBus
++ QtGui
+ ])
+ QT4_BINDIR=`$PKG_CONFIG Qt --variable bindir`
+ AC_CHECK_TOOLS(MOC, [moc-qt4 moc],, [$QT4_BINDIR:$PATH])
diff --git a/x11-misc/lightdm/files/lightdm-1.7.7-session-wrapper.patch b/x11-misc/lightdm/files/lightdm-1.7.7-session-wrapper.patch
new file mode 100644
index 000000000000..40b4159755a2
--- /dev/null
+++ b/x11-misc/lightdm/files/lightdm-1.7.7-session-wrapper.patch
@@ -0,0 +1,13 @@
+Index: lightdm-1.7.7/data/lightdm.conf
+===================================================================
+--- lightdm-1.7.7.orig/data/lightdm.conf
++++ lightdm-1.7.7/data/lightdm.conf
+@@ -87,7 +87,7 @@
+ #user-session=default
+ #allow-guest=true
+ #guest-session=UNIMPLEMENTED
+-#session-wrapper=lightdm-session
++session-wrapper=/etc/lightdm/Xsession
+ #greeter-wrapper=
+ #display-setup-script=
+ #greeter-setup-script=
diff --git a/x11-misc/lightdm/files/lightdm-autologin b/x11-misc/lightdm/files/lightdm-autologin
new file mode 100644
index 000000000000..decfba3438b7
--- /dev/null
+++ b/x11-misc/lightdm/files/lightdm-autologin
@@ -0,0 +1,6 @@
+auth optional pam_env.so
+auth required pam_nologin.so
+auth required pam_permit.so
+
+account include system-local-login
+session include system-local-login
diff --git a/x11-misc/lightdm/files/lightdm.service b/x11-misc/lightdm/files/lightdm.service
new file mode 100644
index 000000000000..7eb46cebaa10
--- /dev/null
+++ b/x11-misc/lightdm/files/lightdm.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Light Display Manager
+Documentation=man:lightdm(1)
+After=systemd-user-sessions.service
+
+[Service]
+ExecStart=/usr/sbin/lightdm
+StandardOutput=syslog
+Restart=always
+IgnoreSIGPIPE=no
+BusName=org.freedesktop.DisplayManager
+
+[Install]
+Alias=display-manager.service
diff --git a/x11-misc/lightdm/files/session-wrapper-lightdm.patch b/x11-misc/lightdm/files/session-wrapper-lightdm.patch
new file mode 100644
index 000000000000..9f41816a9f5f
--- /dev/null
+++ b/x11-misc/lightdm/files/session-wrapper-lightdm.patch
@@ -0,0 +1,13 @@
+Index: lightdm-1.0.6/data/lightdm.conf
+===================================================================
+--- lightdm-1.0.6.orig/data/lightdm.conf
++++ lightdm-1.0.6/data/lightdm.conf
+@@ -65,7 +65,7 @@
+ #user-session=default
+ #allow-guest=true
+ #guest-session=UNIMPLEMENTED
+-#session-wrapper=lightdm-session
++session-wrapper=/etc/lightdm/Xsession
+ #display-setup-script=
+ #greeter-setup-script=
+ #session-setup-script=