summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-24 16:58:25 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-24 17:55:53 +0200
commit01053ffcab41cf08c83b048fc10325f41eec6511 (patch)
tree7b2c9d81e956c4980689c16faa670e425a3d2b3f /x11-misc/lineak-xosdplugin/lineak-xosdplugin-0.9.0-r2.ebuild
parentnet-analyzer/nessus-bin: bump (diff)
downloadgentoo-01053ffcab41cf08c83b048fc10325f41eec6511.tar.gz
gentoo-01053ffcab41cf08c83b048fc10325f41eec6511.tar.bz2
gentoo-01053ffcab41cf08c83b048fc10325f41eec6511.zip
x11-misc/lineak-xosdplugin: EAPI=7
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/lineak-xosdplugin/lineak-xosdplugin-0.9.0-r2.ebuild')
-rw-r--r--x11-misc/lineak-xosdplugin/lineak-xosdplugin-0.9.0-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/lineak-xosdplugin/lineak-xosdplugin-0.9.0-r2.ebuild b/x11-misc/lineak-xosdplugin/lineak-xosdplugin-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..aea5af6276d8
--- /dev/null
+++ b/x11-misc/lineak-xosdplugin/lineak-xosdplugin-0.9.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib
+
+MY_P=${P/.0/}
+
+DESCRIPTION="Xosd plugin for LINEAK"
+HOMEPAGE="http://lineak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="
+ =x11-misc/lineakd-${PV}*
+ x11-libs/xosd
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+)
+
+src_configure() {
+ econf $(use_enable debug) --with-x
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PLUGINDIR=/usr/$(get_libdir)/lineakd/plugins \
+ install
+
+ dodoc AUTHORS README
+}