summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/lsw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/lsw')
-rw-r--r--x11-misc/lsw/Manifest1
-rw-r--r--x11-misc/lsw/lsw-0.3.ebuild38
-rw-r--r--x11-misc/lsw/metadata.xml5
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/lsw/Manifest b/x11-misc/lsw/Manifest
new file mode 100644
index 000000000000..c1db6fda5a90
--- /dev/null
+++ b/x11-misc/lsw/Manifest
@@ -0,0 +1 @@
+DIST lsw-0.3.tar.gz 2723 SHA256 0b3f3ce16eef060df6e0d90327ee82593dfd75281347908698747cfa3f8d0655 SHA512 54f5aeb6d17fe23a2e65fbbf4a7622c194e776261a6f0c04ece54fbf212588ec749d5bf5939a6084997f36468339f5373169234c671211a2b7712c408cf883d8 WHIRLPOOL 2b3fcd30ebf466a0ec0b78b3b9995545f0a24c4720076b5692f166ee2e342a87d85969372f830a1fbbf339cdff1545a6d846f029104f94a7ac03db34f5ca6ee8
diff --git a/x11-misc/lsw/lsw-0.3.ebuild b/x11-misc/lsw/lsw-0.3.ebuild
new file mode 100644
index 000000000000..504a7921d8d5
--- /dev/null
+++ b/x11-misc/lsw/lsw-0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="list window names"
+HOMEPAGE="http://tools.suckless.org/lsw"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -i config.mk \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/{s| -Os||;s|=|+=|}' \
+ -e '/^LDFLAGS/{s|=|+=|;s| -s||}' || die
+ sed -i \
+ -e 's|^\t@|\t|g' \
+ -e '/^\techo/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ doman ${PN}.1
+ dobin ${PN}
+}
diff --git a/x11-misc/lsw/metadata.xml b/x11-misc/lsw/metadata.xml
new file mode 100644
index 000000000000..540f810e069d
--- /dev/null
+++ b/x11-misc/lsw/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>