summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-11 23:58:21 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-12 01:24:34 -0500
commit05e52fd3f0597b4244e78ed5cff4eaada78f8288 (patch)
tree55ea2a877735877fbf2ac4dc5c2f8d8044025368 /x11-misc/menulibre
parentx11-misc/menulibre: mark ALLARCHES (diff)
downloadgentoo-05e52fd3f0597b4244e78ed5cff4eaada78f8288.tar.gz
gentoo-05e52fd3f0597b4244e78ed5cff4eaada78f8288.tar.bz2
gentoo-05e52fd3f0597b4244e78ed5cff4eaada78f8288.zip
x11-misc/menulibre: add 2.2.3, modernize and enable py3.10
I don't use this but side-bumping it, hopefully works as expected and in a better state for future maintainers. Timestamp issues (bug #833127) happened only when building for two python targets, however there is no (known) reason to do this and switched to single impl and pep517. Removed part of the .desktop sed that did not change anything anymore, and simplified LINGUAS workaround (the only case that matters is a set empty LINGUAS, the rest is handled correctly and no need for `has`). Removed X-specific deps, this runs on wayland too. Also removed pyxdg and gtksourceview that appears unused (despite upstream mentioning sourceview in the README). Closes: https://bugs.gentoo.org/787863 Closes: https://bugs.gentoo.org/811387 Closes: https://bugs.gentoo.org/811390 Closes: https://bugs.gentoo.org/823863 Closes: https://bugs.gentoo.org/833127 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/menulibre')
-rw-r--r--x11-misc/menulibre/Manifest1
-rw-r--r--x11-misc/menulibre/menulibre-2.2.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/menulibre/Manifest b/x11-misc/menulibre/Manifest
index cb8b268cdf89..de9b794b1afc 100644
--- a/x11-misc/menulibre/Manifest
+++ b/x11-misc/menulibre/Manifest
@@ -1 +1,2 @@
DIST menulibre-2.2.1.tar.gz 453217 BLAKE2B 86b3d2d8b20bfc7dcfcba380f656ec1e99f1d5dbc3779eadb9e7cc3a2b8c96afc0c2efe72802d0c93833f6c705c67d05a4ba6cc6cf9b95e0c9b9850ae4424fee SHA512 cf1425d604af26b7bde92106aa758a1f7dcc66ad1fbcdcd4c23db90bc7b6de5fe1160b917035f1d949daa1af8ba6b1145d7376ae637c8937a25cb108bf8cd15f
+DIST menulibre-2.2.3.tar.gz 488117 BLAKE2B 2bb157f6f8fb1af8c5059bfa2f93dbf99eb3a0cf9b3072cae28284d50c6a7d847da7a7dc5905ff59386f7d69029f7ffd7c39cb9137e029355fea2f52741283c6 SHA512 bd554606ad35cdd41272ed656427ae3f610d6aacfc9e91e4de6ed342034e1bb6070812017a1372d04b0df4008ae1cd7207ca243142a874b6abb0a00893740da3
diff --git a/x11-misc/menulibre/menulibre-2.2.3.ebuild b/x11-misc/menulibre/menulibre-2.2.3.ebuild
new file mode 100644
index 000000000000..c705b00a9a50
--- /dev/null
+++ b/x11-misc/menulibre/menulibre-2.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+inherit distutils-r1 xdg
+
+DESCRIPTION="Advanced freedesktop.org compliant menu editor"
+HOMEPAGE="https://bluesabre.org/menulibre/"
+SRC_URI="https://github.com/bluesabre/menulibre/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ gnome-base/gnome-menus:3[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-themes/hicolor-icon-theme"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]')"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # show desktop entry in all DEs
+ sed -i '/^OnlyShowIn/d' menulibre.desktop.in || die
+
+ # workaround incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ ! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+}