summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-13 19:11:20 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-13 19:17:31 +0100
commitb82910546ce3f9afa754fb6652b5437c5d036e4c (patch)
tree399f0e5382f1c6b2414a3f4514d2b2985cd69583 /x11-misc/notification-daemon
parentkde-apps/kate: Drop old (diff)
downloadgentoo-b82910546ce3f9afa754fb6652b5437c5d036e4c.tar.gz
gentoo-b82910546ce3f9afa754fb6652b5437c5d036e4c.tar.bz2
gentoo-b82910546ce3f9afa754fb6652b5437c5d036e4c.zip
x11-misc/notification-daemon: version bump to 3.18.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-misc/notification-daemon')
-rw-r--r--x11-misc/notification-daemon/Manifest1
-rw-r--r--x11-misc/notification-daemon/notification-daemon-3.18.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/notification-daemon/Manifest b/x11-misc/notification-daemon/Manifest
index 2b5d6d82d7a9..8f4f2c467709 100644
--- a/x11-misc/notification-daemon/Manifest
+++ b/x11-misc/notification-daemon/Manifest
@@ -2,3 +2,4 @@ DIST notification-daemon-0.5.0.tar.bz2 330034 SHA256 aa1d3546fd1d5c51087317f4921
DIST notification-daemon-0.7.6.tar.xz 279488 SHA256 64d0ce6fb12c94c3b73b701502c804c408cb5a94580bcae5ac37607639f7a0b3 SHA512 b781eef6b0a0208726c669083f024047651e2cf4ab79275076b6c36d2c6b551349a085618828bf4d8c013367be3c88c660d3231c8a6c6ce37cb6c6b0e436ed44 WHIRLPOOL 7f8e1ab298df8e945511eb438afae0943cc9da193c6a5cd0c36ed0a0bcf15c5553e8ff1b918c9a3c23cc534ff747a8a2e370e48a46f408b39abbdb0a1af85897
DIST notification-daemon-3.14.1.tar.xz 280344 SHA256 3cd9af77708fb1ab95ed6c8c66095c5c99a19e84eadc6ba607ef07973e262b80 SHA512 977d028206d6a2005d346f697af5790b404f56399c451774037db25e37724f0cfbd558ae413c9ada40d2d7f399c1911392b19194e8fd093de74f65a6783ccc05 WHIRLPOOL 6c4161a75cdf4db1c99ebc8ede36c4229de1a491a3d5aefab41279b934a95c73dca1799848bd62c63aea31c282d56afeced73f7c51ee36821b642d3490cf08cc
DIST notification-daemon-3.16.1.tar.xz 280404 SHA256 256b322f5d18d438c3f1b0d1d10b6b1fbcff80f82f785e3fc69680e4e498fd81 SHA512 02971b68c5f16d5cf7760915040ac6336a540cda4fd85766e4597a9df3fc4971d7f12f8023a84e55c5cc90c79ea5c685b440411854d2113a719474347c8c4979 WHIRLPOOL 21f06857caf115cd4d53de14e9531a09ade102d378c1a80ba779f4c4cf7b392ae31c50cf7c148aa21800e882a3cd4bd10ba64ae197fd56e560ce050d2875d307
+DIST notification-daemon-3.18.1.tar.xz 327140 SHA256 5c3c86d677884b648bff58985fd3f5eb67d1fc92b78161f1e2e1dc5be91f5d05 SHA512 f21fe99e9c12debd05212e45c4887371ea985182bdf5d3559aef6a912ff87f717a3856976bf4bba0c49c4d188a7ef7503893389c7ca193f02ec7aa4bbcb38717 WHIRLPOOL 8489d91eeec979237c338f5ae82a191fe25b214506d7aca2245c32124ac044f0f2147549b59d29a1412d146e05bd6005b866e918660a472c59ea52c8b6122c5d
diff --git a/x11-misc/notification-daemon/notification-daemon-3.18.1.ebuild b/x11-misc/notification-daemon/notification-daemon-3.18.1.ebuild
new file mode 100644
index 000000000000..31471ebbc5ea
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-3.18.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit gnome.org
+
+DESCRIPTION="Notification daemon"
+HOMEPAGE="https://git.gnome.org/browse/notification-daemon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.15.2:3
+ sys-apps/dbus
+ x11-libs/libX11
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ default
+
+ cat <<-EOF > "${T}"/org.freedesktop.Notifications.service
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/notification-daemon
+ EOF
+
+ insinto /usr/share/dbus-1/services
+ doins "${T}"/org.freedesktop.Notifications.service
+}