summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/openbox-menu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/openbox-menu')
-rw-r--r--x11-misc/openbox-menu/Manifest2
-rw-r--r--x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch81
-rw-r--r--x11-misc/openbox-menu/metadata.xml16
-rw-r--r--x11-misc/openbox-menu/openbox-menu-0.5.1.ebuild43
-rw-r--r--x11-misc/openbox-menu/openbox-menu-0.7.0.ebuild43
5 files changed, 185 insertions, 0 deletions
diff --git a/x11-misc/openbox-menu/Manifest b/x11-misc/openbox-menu/Manifest
new file mode 100644
index 000000000000..5d7e3a1b85d3
--- /dev/null
+++ b/x11-misc/openbox-menu/Manifest
@@ -0,0 +1,2 @@
+DIST openbox-menu-0.5.1.tar.bz2 23027 SHA256 328f669e96919e94c13f77cad755625c23b9f9cef9a8a0eb2e7a5a8621b56387 SHA512 3c794413a7a1ecc7823c3d50c3b5aaca31cdb4f919aeb2b9cb4e04583a417329fc7e3a751d115170b12099ca9b4fb958cd44347558453140863a1f3b7b765b06 WHIRLPOOL 1f4ef46ea7e357a5c0ad25c6b99a0d6e106c27d0021c588e32361440125b3012a23d97f65b6225cff6fce9344698d7547532db8e3f6529a26bf80f66df13a4aa
+DIST openbox-menu-0.7.0.tar.bz2 23088 SHA256 00964fc4798152393c49a5bc41afbf5e04af07ef250ef61309091f95ff96542d SHA512 21684097ffdfce625761b059d26a29dca27b1d79251c7f1d9ef4017b1af6be321059ce9e52349a5e8e40a4e54493ab920cf193d87f5b0d4f96a498da594abb8e WHIRLPOOL f488388a9c789a5ccc92125e4a02319add1a88747fc94eb9a7dbcb868271c596b01ec7ee41177ba07cb7afe540fbef24f36dce12e5ef3ca54e199b83160b8ece
diff --git a/x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch b/x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch
new file mode 100644
index 000000000000..5750e982be10
--- /dev/null
+++ b/x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch
@@ -0,0 +1,81 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Aug 21 14:26:38 UTC 2013
+Subject: several QA fixes
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,17 +1,27 @@
+-LIBS= `pkg-config --libs glib-2.0 gtk+-2.0 libmenu-cache`
+-CFLAGS+= -g -Wall `pkg-config --cflags glib-2.0 gtk+-2.0 libmenu-cache`
+-CC=gcc
++CC ?= gcc
++PKG_CONFIG ?= pkg-config
++
++CFLAGS ?= -O2 -g
++CFLAGS += -Wall $(shell $(PKG_CONFIG) --cflags glib-2.0 gtk+-2.0 libmenu-cache)
++LIBS += $(shell $(PKG_CONFIG) --libs glib-2.0 gtk+-2.0 libmenu-cache)
+ #-DG_DISABLE_DEPRECATED
+
+-# Comment this line if you don't want icons to appear in menu
+-CFLAGS+=-DWITH_ICONS
+-# Uncomment this line if Openbox can display SVG icons
+-# Check SVG support with '$ ldd /usr/bin/openbox | grep svg', librsvg must appear..
+-# CFLAGS+=-DWITH_SVG
+-
+-prefix= /usr/local
+-DESTDIR ?= $(prefix)
+-BINDIR= ${DESTDIR}/bin
++# set to 0 to turn off icons in menus
++ICONS=1
++
++# set to 0 to turn off svg icons in menus
++SVG_ICONS=1
++
++ifeq ($(SVG_ICONS),1)
++CPPFLAGS += -DWITH_SVG
++endif
++
++ifeq ($(ICONS),1)
++CPPFLAGS += -DWITH_ICONS
++endif
++
++prefix = /usr
++BINDIR = ${prefix}/bin
+
+ SRC= $(shell ls *.c 2> /dev/null)
+ OBJ= $(SRC:.c=.o)
+@@ -19,26 +29,29 @@
+ all: $(OBJ) openbox-menu
+
+ %.o: %.c
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ openbox-menu: $(OBJ)
+- $(CC) $(OBJ) -o openbox-menu $(LDFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(OBJ) -o openbox-menu $(LDFLAGS) $(LIBS)
+
+-.PHONY: clean install doc changelog check
++.PHONY: clean install install-strip doc changelog check
+
+ clean:
+ @rm -f *.o openbox-menu
+ @rm -rf doc
+
+ install:
++ @install -Dm 755 openbox-menu "$(DESTDIR)$(BINDIR)/openbox-menu"
++
++install-strip:
+ @strip -s openbox-menu
+- @install -Dm 755 openbox-menu $(BINDIR)/openbox-menu
++ @install -Dm 755 openbox-menu "$(DESTDIR)$(BINDIR)/openbox-menu"
+
+ doc:
+ robodoc --src . --doc doc/ --multidoc --index --html --cmode
+
+ check: openbox-menu
+- ./openbox-menu > test.xml
++ ./openbox-menu > test.xml
+ xmllint test.xml
+ rm test.xml
+
diff --git a/x11-misc/openbox-menu/metadata.xml b/x11-misc/openbox-menu/metadata.xml
new file mode 100644
index 000000000000..3ec7e75078cb
--- /dev/null
+++ b/x11-misc/openbox-menu/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+<upstream>
+<maintainer status="active">
+<email>mimasgpc@free.fr</email>
+</maintainer>
+<doc lang="en">http://mimasgpc.free.fr/openbox-menu_en.html</doc>
+</upstream>
+<use>
+<flag name='icons'>Enable support for icons in menus</flag>
+<flag name='svg'>Support SVG icons</flag>
+</use>
+</pkgmetadata>
+
diff --git a/x11-misc/openbox-menu/openbox-menu-0.5.1.ebuild b/x11-misc/openbox-menu/openbox-menu-0.5.1.ebuild
new file mode 100644
index 000000000000..6c6e36cd0d26
--- /dev/null
+++ b/x11-misc/openbox-menu/openbox-menu-0.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Another dynamic menu generator for Openbox"
+HOMEPAGE="http://mimasgpc.free.fr/openbox-menu_en.html"
+SRC_URI="https://bitbucket.org/fabriceT/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+icons svg"
+REQUIRED_USE="svg? ( icons )"
+
+CDEPEND="
+ dev-libs/glib:2
+ lxde-base/menu-cache
+ x11-libs/gtk+:2
+"
+RDEPEND="
+ ${CDEPEND}
+ icons? ( x11-wm/openbox[imlib,svg?] )
+ !icons? ( x11-wm/openbox )
+"
+DEPEND="
+ ${CDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.0-build.patch
+ epatch_user
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ emake \
+ $(usex icons 'ICONS=1' 'ICONS=0') \
+ $(usex svg 'SVG_ICONS=1' 'SVG_ICONS=0')
+}
diff --git a/x11-misc/openbox-menu/openbox-menu-0.7.0.ebuild b/x11-misc/openbox-menu/openbox-menu-0.7.0.ebuild
new file mode 100644
index 000000000000..1a4fc20dc2a7
--- /dev/null
+++ b/x11-misc/openbox-menu/openbox-menu-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Another dynamic menu generator for Openbox"
+HOMEPAGE="http://mimasgpc.free.fr/openbox-menu_en.html"
+SRC_URI="https://bitbucket.org/fabriceT/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+icons svg"
+REQUIRED_USE="svg? ( icons )"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ lxde-base/menu-cache
+ x11-libs/gtk+:2
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ icons? ( x11-wm/openbox[imlib,svg?] )
+ !icons? ( x11-wm/openbox )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.0-build.patch
+ epatch_user
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ emake \
+ $(usex icons 'ICONS=1' 'ICONS=0') \
+ $(usex svg 'SVG_ICONS=1' 'SVG_ICONS=0')
+}