summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-03-02 20:14:58 +0200
committerDavid Seifert <soap@gentoo.org>2017-03-04 16:18:52 +0100
commit04f6fc2cbc8cae4b77185f7466bdb0981cdf6b8f (patch)
treea6eb5ebe106d436401ce35240ae49599fd110e11 /x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
parentx11-misc/superswitcher: EAPI bump 4 -> 6 (diff)
downloadgentoo-04f6fc2cbc8cae4b77185f7466bdb0981cdf6b8f.tar.gz
gentoo-04f6fc2cbc8cae4b77185f7466bdb0981cdf6b8f.tar.bz2
gentoo-04f6fc2cbc8cae4b77185f7466bdb0981cdf6b8f.zip
x11-misc/oroborus-keylaunch: EAPI bump 4 -> 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4098
Diffstat (limited to 'x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild')
-rw-r--r--x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
new file mode 100644
index 000000000000..b4f28a884834
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/oroborus-//}
+
+DESCRIPTION="utility for binding keys in Oroborus"
+HOMEPAGE="http://www.oroborus.org"
+SRC_URI="mirror://debian/pool/main/k/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ !x11-wm/oroborus-extras"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+DOCS=( README docs/example_rc debian/changelog )
+
+src_prepare() {
+ default
+ sed -e "s: -g -O2 -Wall::" \
+ -e "/^install:/s/install-docs//" \
+ -i Makefile.in || die
+}
+
+src_compile() {
+ emake VERBOSE=1
+}