summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/piedock/piedock-1.6.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/piedock/piedock-1.6.6.ebuild')
-rw-r--r--x11-misc/piedock/piedock-1.6.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/piedock/piedock-1.6.6.ebuild b/x11-misc/piedock/piedock-1.6.6.ebuild
new file mode 100644
index 000000000000..788f26d0c881
--- /dev/null
+++ b/x11-misc/piedock/piedock-1.6.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A little bit like the famous OS X dock but in shape of a pie menu"
+HOMEPAGE="http://markusfisch.de/PieDock"
+SRC_URI="http://markusfisch.de/downloads/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk kde"
+
+RDEPEND="
+ media-libs/libpng
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXrender
+ gtk? (
+ dev-libs/atk
+ dev-libs/glib
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ )
+ kde? (
+ kde-base/kdelibs:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( res/${PN}rc.sample AUTHORS ChangeLog NEWS )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.6.1-signals.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk) \
+ $(use_enable kde) \
+ --bindir="${EPREFIX}"/usr/bin \
+ --enable-xft \
+ --enable-xmu \
+ --enable-xrender
+}