summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-05 17:58:47 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-05 20:07:26 +0100
commit1d67c69e9d50c392120167189765e5b1288fbb41 (patch)
tree4b61ccf906c570d3a8c761882b7d352cc0d900d9 /x11-misc/pypanel
parentx11-misc/rendercheck: Drop old EAPI 3 (diff)
downloadgentoo-1d67c69e9d50c392120167189765e5b1288fbb41.tar.gz
gentoo-1d67c69e9d50c392120167189765e5b1288fbb41.tar.bz2
gentoo-1d67c69e9d50c392120167189765e5b1288fbb41.zip
x11-misc/pypanel: EAPI bump 3 -> 6, port to new python eclasses
Fixes: https://bugs.gentoo.org/599778 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3832
Diffstat (limited to 'x11-misc/pypanel')
-rw-r--r--x11-misc/pypanel/pypanel-2.4-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/pypanel/pypanel-2.4-r2.ebuild b/x11-misc/pypanel/pypanel-2.4-r2.ebuild
new file mode 100644
index 000000000000..33f7843254c9
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-2.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/pyp/PyP}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A lightweight panel/taskbar for X11 window managers"
+HOMEPAGE="http://pypanel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-libs/imlib2[X]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}