summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-15 10:40:41 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-15 10:41:50 +0200
commitbe02695b284d77b4820bc536e549145077a9106f (patch)
tree3b5dd18389a6d4eb9beb8a506a23e98b369e3dbf /x11-misc/revelation/revelation-0.4.14-r2.ebuild
parentmedia-libs/harfbuzz: ia64 stable, bug #624312 (diff)
downloadgentoo-be02695b284d77b4820bc536e549145077a9106f.tar.gz
gentoo-be02695b284d77b4820bc536e549145077a9106f.tar.bz2
gentoo-be02695b284d77b4820bc536e549145077a9106f.zip
x11-misc/revelation: patch to use pycryptodome, bug 611648
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-misc/revelation/revelation-0.4.14-r2.ebuild')
-rw-r--r--x11-misc/revelation/revelation-0.4.14-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/revelation/revelation-0.4.14-r2.ebuild b/x11-misc/revelation/revelation-0.4.14-r2.ebuild
new file mode 100644
index 000000000000..0d8989e0b829
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.4.14-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 gnome2
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="http://revelation.olasagasti.info/"
+SRC_URI="https://www.bitbucket.org/erikg/revelation/downloads/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/libgnome-python[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-libs/cracklib[python,${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-random.patch" \
+ "${FILESDIR}/${P}-xor.patch"
+ eapply_user
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --without-applet \
+ --disable-desktop-update \
+ --disable-mime-update
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${ED}"
+}