summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-02 01:25:50 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-02 01:30:22 +0100
commit9daf75a6a9a064eaa607ad190b4a9e3ea59c7eef (patch)
tree32a9ea7178f9f0e44858e7d46c3f42ef0fc41b64 /x11-misc/rofi/rofi-99999.ebuild
parentx11-misc/rofi: Version 1.5.2 (diff)
downloadgentoo-9daf75a6a9a064eaa607ad190b4a9e3ea59c7eef.tar.gz
gentoo-9daf75a6a9a064eaa607ad190b4a9e3ea59c7eef.tar.bz2
gentoo-9daf75a6a9a064eaa607ad190b4a9e3ea59c7eef.zip
x11-misc/rofi: Add live ebuild
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/rofi/rofi-99999.ebuild')
-rw-r--r--x11-misc/rofi/rofi-99999.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/rofi/rofi-99999.ebuild b/x11-misc/rofi/rofi-99999.ebuild
new file mode 100644
index 000000000000..8533b2dbdb9c
--- /dev/null
+++ b/x11-misc/rofi/rofi-99999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3 toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}