summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-27 10:07:14 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-27 10:07:25 +0200
commit7e9f67d9c6d9de0c1c8671fb9cc6995054cf8694 (patch)
treebad889144261c6d335d9bac563ffca575b732ef6 /x11-misc/rofi
parent0sys-block/di: Bump to version 4.47.1 (diff)
downloadgentoo-7e9f67d9c6d9de0c1c8671fb9cc6995054cf8694.tar.gz
gentoo-7e9f67d9c6d9de0c1c8671fb9cc6995054cf8694.tar.bz2
gentoo-7e9f67d9c6d9de0c1c8671fb9cc6995054cf8694.zip
x11-misc/rofi: Version 1.5.4
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/rofi')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.5.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 5b9c70f5e46d..ad523612c0a2 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,2 +1,3 @@
DIST rofi-1.5.2.tar.xz 377732 BLAKE2B 560c5a4d30d143cbb5ca9030086d614a8f56a5e17b75c1b3f3a2e57bbd16de304b733bc4fd6093e716c993051e238811e9e65ffbf165d2ae4723f0bde1b15b42 SHA512 8fbbcaa040148d204878380f7cb96fa31228f72b68a97a5bcf8d8cd69740f6b185f5e5d2bc2e1d35e267a84b21576eb356c33be827fd1b767460665493360c16
DIST rofi-1.5.3.tar.xz 383016 BLAKE2B 8898af3df161b668b506e5d56a031081c911efc2be37f2dc687e068b58afe906cf9d4186bb166fa953de98eb758d4d125443c6122ccd5c2a861b25cd0473f70c SHA512 6dc4b3c2818f4606e42e8185032788d40c4dae9e67596b3b7f767e8f6ca2963b85602baa4287474520ecdb8e333ae211fce5e7252f3b95e0f90b862040aad117
+DIST rofi-1.5.4.tar.gz 535259 BLAKE2B 8560dfee631c66a6f2178c0af6926ef317ed6d2cfe3ae46264e5b1ce429113ce810e4fed4c86a81acbbd51c85ad2593f40a39d982d7da0aa8ccc55537cadd2bb SHA512 181dedb0905bfab76f7ad313d299f4c80ee4efb11a2c6345b16044b7fb3f54bc7e304ee9352e562932e55108e328e5f6bd2c1d7fd9bcdec3d8022c2dc4f8d394
diff --git a/x11-misc/rofi/rofi-1.5.4.ebuild b/x11-misc/rofi/rofi-1.5.4.ebuild
new file mode 100644
index 000000000000..bd6bafcb7798
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.5.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}