summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-03-14 21:54:48 +0100
committerSebastian Pipping <sping@gentoo.org>2024-03-14 22:11:53 +0100
commit07a8db8179d87bfb26d091aa2b329d58c31993db (patch)
tree9776967328b9d69c683fad0d4fde45db8ffbec4c /x11-misc/safeeyes
parentdev-gap/digraphs: add 1.7.1, drop 1.6.3-r2 (diff)
downloadgentoo-07a8db8179d87bfb26d091aa2b329d58c31993db.tar.gz
gentoo-07a8db8179d87bfb26d091aa2b329d58c31993db.tar.bz2
gentoo-07a8db8179d87bfb26d091aa2b329d58c31993db.zip
x11-misc/safeeyes: Move assets and .desktop file in place
Closes: https://bugs.gentoo.org/926816 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'x11-misc/safeeyes')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.6-r3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.6-r3.ebuild b/x11-misc/safeeyes/safeeyes-2.1.6-r3.ebuild
new file mode 100644
index 000000000000..7f1927eab085
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.6-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1 pypi
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py312.patch
+)
+
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+python_install() {
+ distutils-r1_python_install
+
+ # Workaround for https://bugs.gentoo.org/926816
+ # Files were misplaced and also duplicate across Python slots.
+ local misplaced_usr="${D}/usr/lib/${EPYTHON}/site-packages/usr"
+ local i
+ for i in applications icons ; do
+ local source="${misplaced_usr}/share/${i}"
+ local target="${D}/usr/share/${i}"
+ if [[ ! -d "${target}" ]]; then
+ dodir /usr/share/
+ mv "${source}" "${target}" || die
+ fi
+ done
+ rm -R "${misplaced_usr}" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}