summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-28 23:58:54 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-28 23:59:12 +0100
commita44f5f77f1a47b52226b871969c49e3096ab1dbd (patch)
treed4b55e4280188d9fe6dcc1bc2fb16f4136308106 /x11-misc/sct/sct-0.3.ebuild
parentapp-text/ghostscript-gpl: Remove old (diff)
downloadgentoo-a44f5f77f1a47b52226b871969c49e3096ab1dbd.tar.gz
gentoo-a44f5f77f1a47b52226b871969c49e3096ab1dbd.tar.bz2
gentoo-a44f5f77f1a47b52226b871969c49e3096ab1dbd.zip
x11-misc/sct: new package.
sct is a CLI tool for setting the colour temperature of your screen. Gentoo-Bug: https://bugs.gentoo.org/606168 Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/sct/sct-0.3.ebuild')
-rw-r--r--x11-misc/sct/sct-0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/sct/sct-0.3.ebuild b/x11-misc/sct/sct-0.3.ebuild
new file mode 100644
index 000000000000..2dde0bf297c3
--- /dev/null
+++ b/x11-misc/sct/sct-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Set color temperature of the screen"
+HOMEPAGE="https://www.umaxx.net/"
+SRC_URI="https://www.umaxx.net/dl/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libXrandr"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:_BSD_SOURCE:_DEFAULT_SOURCE:g' \
+ -i Makefile || die
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}