summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2021-06-26 00:00:00 +0000
committerSam James <sam@gentoo.org>2021-06-27 02:03:37 +0100
commitdf57bc2a679296f027268e4696d2a3e50e01e23a (patch)
tree977ae9f10f47d4a5212173b2950637f664bb2976 /x11-misc/sddm/sddm-0.15.0-r2.ebuild
parentsys-process/parallel: Stabilize 20210522 arm, #797670 (diff)
downloadgentoo-df57bc2a679296f027268e4696d2a3e50e01e23a.tar.gz
gentoo-df57bc2a679296f027268e4696d2a3e50e01e23a.tar.bz2
gentoo-df57bc2a679296f027268e4696d2a3e50e01e23a.zip
x11-misc/sddm: Depend on virtual/libcrypt only with USE="-pam".
Fixes: ecee0fc84188e4955961d5a35bc5a1afeae1eaad Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/sddm/sddm-0.15.0-r2.ebuild')
-rw-r--r--x11-misc/sddm/sddm-0.15.0-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/x11-misc/sddm/sddm-0.15.0-r2.ebuild b/x11-misc/sddm/sddm-0.15.0-r2.ebuild
new file mode 100644
index 000000000000..6c3a8e611fc2
--- /dev/null
+++ b/x11-misc/sddm/sddm-0.15.0-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils systemd user
+
+DESCRIPTION="Simple Desktop Display Manager"
+HOMEPAGE="https://github.com/sddm/sddm"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+
+LICENSE="GPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0 public-domain"
+SLOT="0"
+IUSE="elogind +pam systemd"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.6:5
+ >=dev-qt/qtdbus-5.6:5
+ >=dev-qt/qtgui-5.6:5
+ >=dev-qt/qtdeclarative-5.6:5
+ >=dev-qt/qtnetwork-5.6:5
+ >=x11-base/xorg-server-1.15.1
+ x11-libs/libxcb[xkb]
+ elogind? ( sys-auth/elogind )
+ pam? ( sys-libs/pam )
+ !pam? ( virtual/libcrypt:= )
+ systemd? ( sys-apps/systemd:= )
+ !systemd? ( sys-power/upower )"
+
+DEPEND="${RDEPEND}
+ dev-python/docutils
+ >=dev-qt/linguist-tools-5.6:5
+ >=dev-qt/qttest-5.6:5
+ kde-frameworks/extra-cmake-modules
+ virtual/pkgconfig"
+
+# fix for flags handling and bug 563108
+PATCHES=( "${FILESDIR}/${PN}-0.12.0-respect-user-flags.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PAM=$(usex pam)
+ -DNO_SYSTEMD=$(usex '!systemd')
+ -DUSE_ELOGIND=$(usex 'elogind')
+ -DBUILD_MAN_PAGES=ON
+ -DDBUS_CONFIG_FILENAME="org.freedesktop.sddm.conf"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
+
+ systemd_reenable sddm.service
+}