summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 17:53:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 17:54:47 +0200
commit8e892dae48e6e695e7e809748a94d67e70be6c2f (patch)
tree17ad519397b9f9d6cac91f5eb5c4abf142ebc7bf /x11-misc/sddm
parentapp-office/libreoffice-l10n: 6.0.3.2 version bump (diff)
downloadgentoo-8e892dae48e6e695e7e809748a94d67e70be6c2f.tar.gz
gentoo-8e892dae48e6e695e7e809748a94d67e70be6c2f.tar.bz2
gentoo-8e892dae48e6e695e7e809748a94d67e70be6c2f.zip
x11-misc/sddm: Fix SwitchToGreeter error
Thanks-to: Alexander Miller <alex.miller@gmx.de> Bug: https://bugs.gentoo.org/644718 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'x11-misc/sddm')
-rw-r--r--x11-misc/sddm/files/sddm-0.17.0-switchtogreeter.patch54
-rw-r--r--x11-misc/sddm/sddm-0.17.0-r2.ebuild83
2 files changed, 137 insertions, 0 deletions
diff --git a/x11-misc/sddm/files/sddm-0.17.0-switchtogreeter.patch b/x11-misc/sddm/files/sddm-0.17.0-switchtogreeter.patch
new file mode 100644
index 000000000000..22d2fa4ae9be
--- /dev/null
+++ b/x11-misc/sddm/files/sddm-0.17.0-switchtogreeter.patch
@@ -0,0 +1,54 @@
+Subject: [PATCH] Fix switchToGreeter not available without logind
+From: Alexander Miller <alex.miller@gmx.de>
+
+Seats can't be created until SeatManager's signals are
+connected to the DisplayManager, or the latter won't see
+them and switchToGreeter doesn't work. So split SeatManager
+initialization from its constructor and call initialize it
+only after all connections have been set up in DaemonApp's
+constructor.
+
+With logind there may have been enough delay before seats
+got actually added so things would work, but it's still
+cleaner to fix the order.
+
+Fixes: https://bugs.gentoo.org/644718
+Fixes: https://github.com/sddm/sddm/issues/824
+
+--- a/src/daemon/SeatManager.h
++++ b/src/daemon/SeatManager.h
+@@ -31,8 +31,9 @@ namespace SDDM {
+ class SeatManager : public QObject {
+ Q_OBJECT
+ public:
+- explicit SeatManager(QObject *parent = 0);
++ explicit SeatManager(QObject *parent = 0) {}
+
++ void initialize();
+ void createSeat(const QString &name);
+ void removeSeat(const QString &name);
+ void switchToGreeter(const QString &seat);
+--- a/src/daemon/SeatManager.cpp
++++ b/src/daemon/SeatManager.cpp
+@@ -93,8 +93,7 @@ namespace SDDM {
+ }
+ }
+
+- SeatManager::SeatManager(QObject *parent) : QObject(parent) {
+-
++ void SeatManager::initialize() {
+ if (DaemonApp::instance()->testing() || !Logind::isAvailable()) {
+ //if we don't have logind/CK2, just create a single seat immediately and don't do any other connections
+ createSeat(QStringLiteral("seat0"));
+--- a/src/daemon/DaemonApp.cpp
++++ b/src/daemon/DaemonApp.cpp
+@@ -75,6 +75,9 @@ namespace SDDM {
+
+ // log message
+ qDebug() << "Starting...";
++
++ // initialize seats only after signals are connected
++ m_seatManager->initialize();
+ }
+
+ bool DaemonApp::testing() const {
diff --git a/x11-misc/sddm/sddm-0.17.0-r2.ebuild b/x11-misc/sddm/sddm-0.17.0-r2.ebuild
new file mode 100644
index 000000000000..0baf9364f5e7
--- /dev/null
+++ b/x11-misc/sddm/sddm-0.17.0-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="ar ca cs da de es et fi fr hi_IN hu it ja kk ko lt lv nb nl nn pl pt_BR pt_PT ro ru sk sr sr@ijekavian sr@ijekavianlatin sr@latin sv tr uk zh_CN zh_TW"
+inherit cmake-utils l10n systemd user
+
+DESCRIPTION="Simple Desktop Display Manager"
+HOMEPAGE="https://github.com/sddm/sddm"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+LICENSE="GPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0 public-domain"
+SLOT="0"
+IUSE="consolekit elogind +pam systemd test"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.6:5
+ >=dev-qt/qtdbus-5.6:5
+ >=dev-qt/qtdeclarative-5.6:5
+ >=dev-qt/qtgui-5.6:5
+ >=dev-qt/qtnetwork-5.6:5
+ >=x11-base/xorg-server-1.15.1
+ x11-libs/libXau
+ x11-libs/libxcb[xkb]
+ consolekit? ( >=sys-auth/consolekit-0.9.4 )
+ elogind? ( sys-auth/elogind )
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd:= )
+ !systemd? ( sys-power/upower )"
+
+DEPEND="${RDEPEND}
+ dev-python/docutils
+ >=dev-qt/linguist-tools-5.6:5
+ kde-frameworks/extra-cmake-modules
+ virtual/pkgconfig
+ test? ( >=dev-qt/qttest-5.6:5 )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.12.0-respect-user-flags.patch" # fix for flags handling and bug 563108
+ "${FILESDIR}/${PN}-0.16.0-Xsession.patch" # bug 611210
+ "${FILESDIR}/${PN}-0.16.0-ck2-revert.patch" # bug 633920
+ # not yet upstream, fixing issues caused by hostname changes
+ "${FILESDIR}/${P}-switchtogreeter.patch" # bugs 644718, 649888
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ disable_locale() {
+ sed -e "/${1}\.ts/d" -i data/translations/CMakeLists.txt || die
+ }
+ l10n_find_plocales_changes "data/translations" "" ".ts"
+ l10n_for_each_disabled_locale_do disable_locale
+
+ use test || cmake_comment_add_subdirectory test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PAM=$(usex pam)
+ -DNO_SYSTEMD=$(usex '!systemd')
+ -DUSE_ELOGIND=$(usex 'elogind')
+ -DBUILD_MAN_PAGES=ON
+ -DDBUS_CONFIG_FILENAME="org.freedesktop.sddm.conf"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ sed -i -e "/^InputMethod/s/qtvirtualkeyboard//" "${D}"/etc/sddm.conf || die
+}
+
+pkg_postinst() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
+
+ systemd_reenable sddm.service
+}