summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-15 11:18:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-15 11:20:59 +0200
commit93cd34224fd5a22bb3258a6824a0346f4c8adfa5 (patch)
tree5537ae087fbed56162360603846a4811700d3f84 /x11-misc/sddm
parentapp-text/poppler-data: Bump to version 0.4.8 (diff)
downloadgentoo-93cd34224fd5a22bb3258a6824a0346f4c8adfa5.tar.gz
gentoo-93cd34224fd5a22bb3258a6824a0346f4c8adfa5.tar.bz2
gentoo-93cd34224fd5a22bb3258a6824a0346f4c8adfa5.zip
x11-misc/sddm: Revbump to not show usernames twice (bug #627902).
Permission kindly granted by kensington. Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'x11-misc/sddm')
-rw-r--r--x11-misc/sddm/files/sddm-0.14.0-nsswitch_conf.patch27
-rw-r--r--x11-misc/sddm/sddm-0.14.0-r4.ebuild90
2 files changed, 117 insertions, 0 deletions
diff --git a/x11-misc/sddm/files/sddm-0.14.0-nsswitch_conf.patch b/x11-misc/sddm/files/sddm-0.14.0-nsswitch_conf.patch
new file mode 100644
index 000000000000..371df93e2b8d
--- /dev/null
+++ b/x11-misc/sddm/files/sddm-0.14.0-nsswitch_conf.patch
@@ -0,0 +1,27 @@
+From 1f39c7a91ea4bc9527628adb01cb49173f1e68be Mon Sep 17 00:00:00 2001
+From: Palo Kisa <palo.kisa@gmail.com>
+Date: Fri, 9 Jun 2017 10:13:01 +0200
+Subject: [PATCH] UserModel: Check for duplicates from getpwent()
+
+---
+ src/greeter/UserModel.cpp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/greeter/UserModel.cpp b/src/greeter/UserModel.cpp
+index 94c492d0..33114d08 100644
+--- a/src/greeter/UserModel.cpp
++++ b/src/greeter/UserModel.cpp
+@@ -72,6 +72,13 @@ namespace SDDM {
+ if (mainConfig.Users.HideShells.get().contains(QString::fromLocal8Bit(current_pw->pw_shell)))
+ continue;
+
++ // skip duplicates
++ // Note: getpwent() makes no attempt to suppress duplicate information
++ // if multiple sources are specified in nsswitch.conf(5).
++ if (d->users.cend()
++ != std::find_if(d->users.cbegin(), d->users.cend(), [current_pw](const UserPtr & u) { return u->uid == current_pw->pw_uid; }))
++ continue;
++
+ // create user
+ UserPtr user { new User() };
+ user->name = QString::fromLocal8Bit(current_pw->pw_name);
diff --git a/x11-misc/sddm/sddm-0.14.0-r4.ebuild b/x11-misc/sddm/sddm-0.14.0-r4.ebuild
new file mode 100644
index 000000000000..a79ea8f1a2f8
--- /dev/null
+++ b/x11-misc/sddm/sddm-0.14.0-r4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils user
+
+DESCRIPTION="Simple Desktop Display Manager"
+HOMEPAGE="https://github.com/sddm/sddm"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+LICENSE="GPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0 public-domain"
+SLOT="0"
+IUSE="consolekit elogind +pam systemd"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+RDEPEND=">=dev-qt/qtcore-5.6:5
+ >=dev-qt/qtdbus-5.6:5
+ >=dev-qt/qtgui-5.6:5
+ >=dev-qt/qtdeclarative-5.6:5
+ >=dev-qt/qtnetwork-5.6:5
+ >=x11-base/xorg-server-1.15.1
+ x11-libs/libxcb[xkb(-)]
+ consolekit? ( >=sys-auth/consolekit-0.9.4 )
+ elogind? ( sys-auth/elogind )
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd:= )
+ !systemd? ( || ( sys-power/upower sys-power/upower-pm-utils ) )"
+
+DEPEND="${RDEPEND}
+ dev-python/docutils
+ >=dev-qt/linguist-tools-5.6:5
+ >=dev-qt/qttest-5.6:5
+ kde-frameworks/extra-cmake-modules
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13.0-pam_kwallet.patch"
+ # fix for flags handling and bug 563108
+ "${FILESDIR}/${PN}-0.12.0-respect-user-flags.patch"
+ "${FILESDIR}/${P}-avatars.patch"
+ "${FILESDIR}/${PN}-enable-elogind.patch"
+ "${FILESDIR}/${P}-nsswitch_conf.patch" #627902
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
+ if [[ $(gcc-major-version) -lt 4 || $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 7 ]] ; then
+ die 'The active compiler needs to be gcc 4.7 (or newer)'
+ fi
+ fi
+}
+
+src_prepare() {
+ use consolekit && eapply "${FILESDIR}/${P}-consolekit.patch"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PAM=$(usex pam)
+ -DNO_SYSTEMD=$(usex '!systemd')
+ -DUSE_ELOGIND=$(usex 'elogind')
+ -DBUILD_MAN_PAGES=ON
+ -DDBUS_CONFIG_FILENAME="org.freedesktop.sddm.conf"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
+
+ if use consolekit && use pam && [[ -e "${ROOT}"/etc/pam.d/system-login ]]; then
+ local line=$(grep "pam_ck_connector.*nox11" "${ROOT}"/etc/pam.d/system-login)
+ if [[ -z ${line} ]]; then
+ ewarn
+ ewarn "Erroneous /etc/pam.d/system-login settings detected!"
+ ewarn "Please restore 'nox11' option in the line containing pam_ck_connector:"
+ ewarn
+ ewarn "session optional pam_ck_connector.so nox11"
+ ewarn
+ ewarn "or 'emerge -1 sys-auth/pambase' and run etc-update."
+ ewarn
+ fi
+ fi
+}