summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 16:54:20 +0000
committerSam James <sam@gentoo.org>2021-03-16 19:22:07 +0000
commita6e4b710215acaf0abd4dafb41ccbf9dcfbecb95 (patch)
treea165c8ef4c8d9b6952c5a0856c2a5837851f73e5 /x11-misc/simpleswitcher
parentx11-misc/simpleswitcher: drop 20140219 (diff)
downloadgentoo-a6e4b710215acaf0abd4dafb41ccbf9dcfbecb95.tar.gz
gentoo-a6e4b710215acaf0abd4dafb41ccbf9dcfbecb95.tar.bz2
gentoo-a6e4b710215acaf0abd4dafb41ccbf9dcfbecb95.zip
x11-misc/simpleswitcher: use BDEPEND in EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/simpleswitcher')
-rw-r--r--x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild11
-rw-r--r--x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild10
2 files changed, 9 insertions, 12 deletions
diff --git a/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild b/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild
index e7051abca7cf..830edeee59d4 100644
--- a/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild
+++ b/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
SSHASH="7230421aa2e3364e3b4620f1ea3760f8f810b1a5"
DESCRIPTION="lightweight EWMH window switcher with features and looks of dmenu"
HOMEPAGE="https://github.com/seanpringle/simpleswitcher"
SRC_URI="https://github.com/seanpringle/simpleswitcher/archive/${SSHASH}.tar.gz -> ${P}-${SSHASH}.tar.gz"
+S="${WORKDIR}/${PN}-${SSHASH}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
x11-libs/libX11
x11-libs/libXft
x11-libs/libXinerama
x11-libs/libXres
"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-S=${WORKDIR}/${PN}-${SSHASH}
+DEPEND="${RDEPEND}"
src_compile() {
tc-export CC
diff --git a/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild b/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild
index 24730fddec45..c4313820fcfd 100644
--- a/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild
+++ b/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit git-r3 toolchain-funcs
DESCRIPTION="lightweight EWMH window switcher with features and looks of dmenu"
@@ -10,18 +11,15 @@ EGIT_REPO_URI="https://github.com/seanpringle/simpleswitcher"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
+BDEPEND="virtual/pkgconfig"
RDEPEND="
x11-libs/libX11
x11-libs/libXft
x11-libs/libXinerama
x11-libs/libXres
"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
src_compile() {
tc-export CC