summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngolf Wagner <contact@ingolf-wagner.de>2016-12-21 21:38:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-04 23:55:52 +0200
commit676abc6970aa6853a0220206c174be170bee3070 (patch)
tree416ea8e71c8278a2a3bbe984d41ec81751baa29e /x11-misc/slop/slop-4.3.21.ebuild
parentsys-apps/sysvinit: block <sys-apps/openrc-0.13 (diff)
downloadgentoo-676abc6970aa6853a0220206c174be170bee3070.tar.gz
gentoo-676abc6970aa6853a0220206c174be170bee3070.tar.bz2
gentoo-676abc6970aa6853a0220206c174be170bee3070.zip
x11-misc/slop: add new package
Closes: https://github.com/gentoo/gentoo/pull/2796
Diffstat (limited to 'x11-misc/slop/slop-4.3.21.ebuild')
-rw-r--r--x11-misc/slop/slop-4.3.21.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/slop/slop-4.3.21.ebuild b/x11-misc/slop/slop-4.3.21.ebuild
new file mode 100644
index 000000000000..2a90460ad597
--- /dev/null
+++ b/x11-misc/slop/slop-4.3.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ media-libs/imlib2
+ virtual/opengl
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ )"
+DEPEND="
+ ${RDEPEND}
+ opengl? (
+ media-libs/glm
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3.21-no-cppcheck.patch"
+ "${FILESDIR}/${PN}-4.3.21-no-gengetopt.patch"
+ "${FILESDIR}/${PN}-4.3.21-no-librt.patch"
+)
+
+src_prepare() {
+ use opengl || PATCHES+=( "${FILESDIR}/${PN}-4.3.21-no-opengl.patch" )
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_OPENGL_SUPPORT=$(usex opengl)
+ )
+ cmake-utils_src_configure
+}