summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-12-01 14:43:36 +0100
committerSebastian Pipping <sping@gentoo.org>2020-12-01 14:55:01 +0100
commit64dc247235edca8e453f15c4fde0759ab3c75aae (patch)
tree789cfb41fd5508749e6b9891f5495d9c0bcab124 /x11-misc/spnavcfg
parentx11-wm/herbstluftwm: remove old 0.7.2-r1, 0.8.2 (diff)
downloadgentoo-64dc247235edca8e453f15c4fde0759ab3c75aae.tar.gz
gentoo-64dc247235edca8e453f15c4fde0759ab3c75aae.tar.bz2
gentoo-64dc247235edca8e453f15c4fde0759ab3c75aae.zip
x11-misc/spnavcfg: 0.3.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'x11-misc/spnavcfg')
-rw-r--r--x11-misc/spnavcfg/Manifest1
-rw-r--r--x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/spnavcfg/Manifest b/x11-misc/spnavcfg/Manifest
index 4b3f7fb47ab8..5ca4eeab33db 100644
--- a/x11-misc/spnavcfg/Manifest
+++ b/x11-misc/spnavcfg/Manifest
@@ -1 +1,2 @@
+DIST spnavcfg-0.3.1.tar.gz 215460 BLAKE2B f2bd35022399ec085d5c8b08c7514fdac8e974b33e9923a79446fa9552827d5986abf136fdb95ed31d7dbec419eb34ce13039955c6255cff971ffedcd3cc8a02 SHA512 b5e0ef2036eebc971298d95e8a91bd89ade956933919a4a5dc062fd977ff159bba392b0092ac36142fb317a9758c26319b07680b473f9957eda0163146be5408
DIST spnavcfg-0.3.tar.gz 214774 BLAKE2B aee45a796bd95761e4a7fe922cc5b65185c894e2fa366dea6d7677fc5ac3b7e0345b89eedef7bf8e446c598d66f161bb66fa695c07b433f5a6b7dce5055b6256 SHA512 a3411c32a6c7de2fd1cfa7960e1b0dade88e8c37435a39ded864b4b6f12fd3c8f518dad7a4ac5b465517484e74b3586f12d47e780f655fd7e4c3fea8d6186c80
diff --git a/x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild b/x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild
new file mode 100644
index 000000000000..3f3ca2c51ac4
--- /dev/null
+++ b/x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="GTK-based GUI to configure a space navigator device"
+HOMEPAGE="http://spacenav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/spacenav/spacenavd%20config%20gui/${PN}%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-misc/spacenavd[X]"
+
+src_configure() {
+ econf --disable-debug --disable-opt
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}