summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/stalonetray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/stalonetray')
-rw-r--r--x11-misc/stalonetray/Manifest2
-rw-r--r--x11-misc/stalonetray/metadata.xml11
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.1.ebuild34
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.3.ebuild34
4 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/stalonetray/Manifest b/x11-misc/stalonetray/Manifest
new file mode 100644
index 000000000000..dc2633b04430
--- /dev/null
+++ b/x11-misc/stalonetray/Manifest
@@ -0,0 +1,2 @@
+DIST stalonetray-0.8.1.tar.bz2 150814 SHA256 94a2f80ae211a552c2d379b5b41e2618f3e906b33bee207fec8793b1a9bde8f2
+DIST stalonetray-0.8.3.tar.bz2 155276 SHA256 36548a588b2d466913423245dda6ffb6313132cd0cec635a117d37b3dab5fd4c SHA512 b1c50d844b6497b586c1ad56b721675690ea305a4e3a2601ab5305af0e208c215825eefa8fa374ae0c392252156a8dffd5882992c943344f5b6a674fe6553942 WHIRLPOOL fc0e1a01b98bc4475b2137242a97c58d20113a23f7fb2fd97c94e6c52105080beeeadf6d8f5b1b0da99aa080a1de90e05db3155a7c7d051966b5c6ae8b06e397
diff --git a/x11-misc/stalonetray/metadata.xml b/x11-misc/stalonetray/metadata.xml
new file mode 100644
index 000000000000..77344c741801
--- /dev/null
+++ b/x11-misc/stalonetray/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <use>
+ <flag name="graceful-exit">use non-portable hack to exit gracefuly on signal</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">stalonetray</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/stalonetray/stalonetray-0.8.1.ebuild b/x11-misc/stalonetray/stalonetray-0.8.1.ebuild
new file mode 100644
index 000000000000..6f86670ec196
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="http://stalonetray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +graceful-exit kde"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ $(use_enable kde native-kde)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README stalonetrayrc.sample TODO
+ dohtml stalonetray.html
+}
diff --git a/x11-misc/stalonetray/stalonetray-0.8.3.ebuild b/x11-misc/stalonetray/stalonetray-0.8.3.ebuild
new file mode 100644
index 000000000000..615494594418
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="http://stalonetray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +graceful-exit kde"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ $(use_enable kde native-kde)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README stalonetrayrc.sample TODO
+ dohtml stalonetray.html
+}