summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-08-16 23:22:01 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-08-16 23:24:16 +0200
commit1bc1d2b1c303aec48f30ac3012731edaf51e475b (patch)
treedb47439a91b7f829b889b463ad0a1de83dad4753 /x11-misc/sunflower
parentapp-admin/ansible: fix upgrading ansible from previous versions (diff)
downloadgentoo-1bc1d2b1c303aec48f30ac3012731edaf51e475b.tar.gz
gentoo-1bc1d2b1c303aec48f30ac3012731edaf51e475b.tar.bz2
gentoo-1bc1d2b1c303aec48f30ac3012731edaf51e475b.zip
x11-misc/sunflower: 0.4_p20200716 bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'x11-misc/sunflower')
-rw-r--r--x11-misc/sunflower/Manifest1
-rw-r--r--x11-misc/sunflower/sunflower-0.4_p20200716.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/sunflower/Manifest b/x11-misc/sunflower/Manifest
index 5c5c22b73aca..705cd77bead6 100644
--- a/x11-misc/sunflower/Manifest
+++ b/x11-misc/sunflower/Manifest
@@ -1,2 +1,3 @@
DIST sunflower-0.2-59.tgz 790126 BLAKE2B 32df1ced73ba0bf5e814e52010eefbbd10657bdbb602dd3a48dc08b865195c3d1efa631bfe2d421f0a12a2f01521a2c6248fe5b9ca8fcc268423f0c9aa3d252d SHA512 e97076eb1c57d52b8fd95501259acaaa9a429f9daacc30ef587cce2f3419433f5aa4554e0e86beeceda208b4be425b98c64c6ced04e36e86b2b4f803176c37f9
DIST sunflower-0.3.61.tar.gz 975053 BLAKE2B 5845ce0e81cf98b7488c9c34b8a3b6702e01abe9976bd4186691ce3804164d707d3ca999896e3f8d60e5253891d94f39e2fabdb50170afa8ec0f937df141db89 SHA512 f55c2fb15889f903375776f989498827dcab287e87d4015c50f12780dd2f0271e1e127533a10ca94f44ebd44727018917cf92e828bbe82b7653d8ed559ee1cc3
+DIST sunflower-0.4_p20200716.tar.xz 830248 BLAKE2B 673b320bf08c0e0600fae06a531f75403b0e76bd8a267918986da84537a5213f0a1d99c9de74820f15652b80959e9029566f4611138893f08919f389a66a8032 SHA512 0e30bbadb3d60a64e2a2b629104c2a3ad88d997d581c1c76ef593afa1d3c48aafd185b4cd36da25bed5c3e9b9d1389f0709aaa40e796e883dccfe71b214620ed
diff --git a/x11-misc/sunflower/sunflower-0.4_p20200716.ebuild b/x11-misc/sunflower/sunflower-0.4_p20200716.ebuild
new file mode 100644
index 000000000000..e0b7701fca71
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.4_p20200716.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}