summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-03-02 16:22:52 +0200
committerDavid Seifert <soap@gentoo.org>2017-03-04 16:18:46 +0100
commitfd3736d8c4845ee3eeac7ea1212f17cf81ac783f (patch)
treed525139c275fe2a2b5a04bc02bc3d5622b78cdf4 /x11-misc/superswitcher/superswitcher-0.6-r1.ebuild
parentx11-misc/xmountains: EAPI bump 4 -> 6 (diff)
downloadgentoo-fd3736d8c4845ee3eeac7ea1212f17cf81ac783f.tar.gz
gentoo-fd3736d8c4845ee3eeac7ea1212f17cf81ac783f.tar.bz2
gentoo-fd3736d8c4845ee3eeac7ea1212f17cf81ac783f.zip
x11-misc/superswitcher: EAPI bump 4 -> 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4098
Diffstat (limited to 'x11-misc/superswitcher/superswitcher-0.6-r1.ebuild')
-rw-r--r--x11-misc/superswitcher/superswitcher-0.6-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/superswitcher/superswitcher-0.6-r1.ebuild b/x11-misc/superswitcher/superswitcher-0.6-r1.ebuild
new file mode 100644
index 000000000000..63e4756b5b18
--- /dev/null
+++ b/x11-misc/superswitcher/superswitcher-0.6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A more feature-full replacement of the Alt-Tab window switching behavior"
+HOMEPAGE="https://code.google.com/p/superswitcher/"
+SRC_URI="https://superswitcher.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ >=gnome-base/gconf-2:2
+ x11-libs/gtk+:2
+ >=x11-libs/libwnck-2.10:1
+ x11-libs/libXcomposite
+ x11-libs/libXinerama
+ x11-libs/libXrender"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-wnck-workspace.patch
+ "${FILESDIR}"/${PN}-0.6-glib-single-include.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ src/Makefile.am || die #338906
+
+ mv configure.{in,ac} || die #426262
+
+ eautoreconf
+}