summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-10-26 23:39:02 -0600
committerTim Harder <radhermit@gentoo.org>2020-10-26 23:44:37 -0600
commitce8d7ffee502496f3a49a1b3938b8627d64f5a16 (patch)
tree052c26c87d7ce8cb97dea4c46f14232a4b04bb59 /x11-misc/sxhkd
parentmedia-plugins/gst-plugins-openh264: add subslot operator dep := on openh264 (diff)
downloadgentoo-ce8d7ffee502496f3a49a1b3938b8627d64f5a16.tar.gz
gentoo-ce8d7ffee502496f3a49a1b3938b8627d64f5a16.tar.bz2
gentoo-ce8d7ffee502496f3a49a1b3938b8627d64f5a16.zip
x11-misc/sxhkd: version bump to 0.6.2
Closes: https://bugs.gentoo.org/706674 Closes: https://bugs.gentoo.org/738142 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'x11-misc/sxhkd')
-rw-r--r--x11-misc/sxhkd/Manifest1
-rw-r--r--x11-misc/sxhkd/sxhkd-0.6.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/sxhkd/Manifest b/x11-misc/sxhkd/Manifest
index 6f810d8c8de6..e0fb3c761794 100644
--- a/x11-misc/sxhkd/Manifest
+++ b/x11-misc/sxhkd/Manifest
@@ -1 +1,2 @@
DIST sxhkd-0.6.1.tar.gz 34808 BLAKE2B b25ff934d0a7f28b3950152ef800da90c5f990f2efd92e9178fef8a77939dc1ed1bbde55bb5a990c33fd3d0be7490dfb2e799ca56abf3c3c6f20c258169eb100 SHA512 d8cd6166ff7e7bc800ed79c5d63cbdfad4f9824c5a5e19b6a315b2ec570295150600651376265932f5fde8b6127f629a553337c6454a1c78c62b3395aaeb55a2
+DIST sxhkd-0.6.2.tar.gz 35711 BLAKE2B a1dc409314dda68aa3df99bf584d20e492c7220dceb188b844a6bd9374a4c52b7e1a406b96fc77276498db86dd5e5114a50357ddee660f5f08d6fe974de8f990 SHA512 3f758aec3de76c6336a9008e997317ed7a05db0fcd81025d8f856694c2b8162022e25d9a48876de99056748a2dbe6a561a0e1594973c854ac2c98d44af6b03aa
diff --git a/x11-misc/sxhkd/sxhkd-0.6.2.ebuild b/x11-misc/sxhkd/sxhkd-0.6.2.ebuild
new file mode 100644
index 000000000000..81ef00356ead
--- /dev/null
+++ b/x11-misc/sxhkd/sxhkd-0.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Simple X hotkey daemon"
+HOMEPAGE="https://github.com/baskerville/sxhkd/"
+SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libxcb
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}
+ x11-libs/xcb-util"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr DOCPREFIX="/usr/share/doc/${PF}" install
+ systemd_dounit contrib/systemd/${PN}.service
+}