summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-11-23 14:13:07 +0800
committerYixun Lan <dlan@gentoo.org>2016-11-23 14:15:21 +0800
commit9e226a9a58598800152abf23b25e20dfdf3069bb (patch)
treeffc07858173ab14fb0e753e3cc9d6c685de074e7 /x11-misc/synergy/files
parentapp-admin/puppetserver: cleanup (diff)
downloadgentoo-9e226a9a58598800152abf23b25e20dfdf3069bb.tar.gz
gentoo-9e226a9a58598800152abf23b25e20dfdf3069bb.tar.bz2
gentoo-9e226a9a58598800152abf23b25e20dfdf3069bb.zip
x11-misc/synergy: version bump
Gentoo-Bug: 598802 Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-misc/synergy/files')
-rw-r--r--x11-misc/synergy/files/synergy-1.8.5-gtest.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/synergy/files/synergy-1.8.5-gtest.patch b/x11-misc/synergy/files/synergy-1.8.5-gtest.patch
new file mode 100644
index 000000000000..c9eaa5164190
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.8.5-gtest.patch
@@ -0,0 +1,38 @@
+--- a/src/lib/synergy/KeyMap.h 2016-11-09 13:21:52.000000000 -0600
++++ b/src/lib/synergy/KeyMap.h 2016-11-09 13:22:17.484457330 -0600
+@@ -24,7 +24,9 @@
+ #include "common/stdset.h"
+ #include "common/stdvector.h"
+
++#if WITH_GENTOO_TEST
+ #include "gtest/gtest_prod.h"
++#endif
+
+ namespace synergy {
+
+@@ -327,6 +329,7 @@
+ //@}
+
+
++#if WITH_GENTOO_TEST
+ private:
+ FRIEND_TEST(KeyMapTests,
+ findBestKey_requiredDown_matchExactFirstItem);
+@@ -341,6 +344,7 @@
+ FRIEND_TEST(KeyMapTests,
+ findBestKey_onlyOneRequiredDown_matchTwoRequiredChangesItem);
+ FRIEND_TEST(KeyMapTests, findBestKey_noRequiredDown_cannotMatch);
++#endif
+
+ private:
+ //! Ways to synthesize a key
+--- a/src/CMakeLists.txt 2016-11-09 13:31:26.000000000 -0600
++++ b/src/CMakeLists.txt 2016-11-09 13:40:08.189421727 -0600
+@@ -50,6 +50,6 @@
+ add_subdirectory(cmd)
+ add_subdirectory(micro)
+
+-if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "IRIX")
++if (${WITH_GENTOO_TEST})
+ add_subdirectory(test)
+ endif()