summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-17 08:47:46 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-17 08:48:11 +0200
commitea243755514d7bb4ec68c146fb3c14de4e637c1a (patch)
tree77a8280400ada3ffc95ca1794141c05b8f3bd95c /x11-misc/synergy/files
parentsys-process/audit: stable for alpha amd64 hppa ppc x86 (bug 588734) (diff)
downloadgentoo-ea243755514d7bb4ec68c146fb3c14de4e637c1a.tar.gz
gentoo-ea243755514d7bb4ec68c146fb3c14de4e637c1a.tar.bz2
gentoo-ea243755514d7bb4ec68c146fb3c14de4e637c1a.zip
x11-misc/synergy: Version bump.
- add net-misc/curl dependency for syntool - Hack around false gtest dependency - Split out internal gtest/gmock patch Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/synergy/files')
-rw-r--r--x11-misc/synergy/files/synergy-1.8.1-gtest.patch38
-rw-r--r--x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch23
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/synergy/files/synergy-1.8.1-gtest.patch b/x11-misc/synergy/files/synergy-1.8.1-gtest.patch
new file mode 100644
index 000000000000..3491077a15a1
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.8.1-gtest.patch
@@ -0,0 +1,38 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -19,6 +19,6 @@
+ add_subdirectory(plugin)
+ add_subdirectory(micro)
+
+-if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "IRIX")
++if (${WITH_GENTOO_TEST})
+ add_subdirectory(test)
+ endif()
+--- a/src/lib/synergy/SubscriptionManager.h
++++ b/src/lib/synergy/SubscriptionManager.h
+@@ -20,7 +20,9 @@
+ #include "SubscriptionKey.h"
+ #include "common/common.h"
+
++#if WITH_GENTOO_TEST
+ #include "gtest/gtest_prod.h"
++#endif
+
+ class SubscriptionManager {
+ public:
+@@ -35,6 +37,7 @@
+ //! Use standard output to return subscription filename to gui
+ void printFilename();
+
++#if WITH_GENTOO_TEST
+ private:
+ FRIEND_TEST(SubscriptionTests, decode_invalidLength_throwException);
+ FRIEND_TEST(SubscriptionTests, decode_invalidSerial_outputPlainText);
+@@ -45,6 +48,7 @@
+ FRIEND_TEST(SubscriptionTests, parsePlainSerial_expiredTrialSerial_throwException);
+ FRIEND_TEST(SubscriptionTests, parsePlainSerial_expiredBasicSerial_validSubscriptionKey);
+ FRIEND_TEST(SubscriptionTests, parsePlainSerial_validSerialWithoutCompany_validSubscriptionKey);
++#endif
+
+ private:
+ String decode(const String& input);
diff --git a/x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch b/x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch
new file mode 100644
index 000000000000..7814c7418cd3
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch
@@ -0,0 +1,23 @@
+--- a/src/test/CMakeLists.txt
++++ b/src/test/CMakeLists.txt
+@@ -14,20 +14,5 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-include_directories(
+- ../../ext/gtest-1.6.0
+- ../../ext/gtest-1.6.0/include
+- ../../ext/gmock-1.6.0
+- ../../ext/gmock-1.6.0/include)
+-
+-add_library(gtest STATIC ../../ext/gtest-1.6.0/src/gtest-all.cc)
+-add_library(gmock STATIC ../../ext/gmock-1.6.0/src/gmock-all.cc)
+-
+-if (UNIX)
+- # ignore warnings in gtest and gmock
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
+- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
+-endif()
+-
+ add_subdirectory(integtests)
+ add_subdirectory(unittests)