summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2015-12-27 20:58:19 +0100
committerAmy Winston <amynka@gentoo.org>2015-12-27 20:58:19 +0100
commitca2302350f8bbe7675f907ace7b7ec398f1435d2 (patch)
tree50bf9fabd79a54470b32756379f909069e938c49 /x11-misc/tint2
parentapp-emulation/docker-swarm: version bump to 1.0.1 (diff)
downloadgentoo-ca2302350f8bbe7675f907ace7b7ec398f1435d2.tar.gz
gentoo-ca2302350f8bbe7675f907ace7b7ec398f1435d2.tar.bz2
gentoo-ca2302350f8bbe7675f907ace7b7ec398f1435d2.zip
x11-misc/tint2: version bump 0.12.3 bug #565876.Thanks Anthony Parsons.
Package-Manager: portage-2.2.24
Diffstat (limited to 'x11-misc/tint2')
-rw-r--r--x11-misc/tint2/Manifest1
-rw-r--r--x11-misc/tint2/files/0.12.3-no-hardcode-update-icon-cache.patch21
-rw-r--r--x11-misc/tint2/tint2-0.12.3.ebuild67
3 files changed, 89 insertions, 0 deletions
diff --git a/x11-misc/tint2/Manifest b/x11-misc/tint2/Manifest
index d76be0515621..d69f155a703a 100644
--- a/x11-misc/tint2/Manifest
+++ b/x11-misc/tint2/Manifest
@@ -1 +1,2 @@
DIST tint2-0.11.tar.bz2 91716 SHA256 fe106e6a6057d2631abddde9f82d3fd4fb1985c4fb93f10d3886417a9e22471d SHA512 db88c17780d24b82badbedbce4518d736dfcb2a730ff500bcb36f2b32f65271c2424f0c2a34981f9d3af033b84252db0c8217e2dd7ca57f9a0eadbc98796115c WHIRLPOOL 4c497995bc5713199a8e624ebfa463edbd610b6d948f1cbfce11ec78e4cd2cd6fad51bd58937b0fce343bb86a29a35bc40eec2bafb687c6ee89355bceb5486ec
+DIST tint2-0.12.3.tar.gz 251977 SHA256 655cde38f4d358d69f3628f722c7da7768e193769ac876cc24b59f328bcd3d6c SHA512 8022895617905446bc01e548ece9df63d32ae1ef3bafc2de2c79fb2c0e91ab78d036e8c9165ea4d4224dd70edb510266bbea47baf382abbf27a275b60b7d1465 WHIRLPOOL 057ba74074d5e013d9c882a6cbef1bd75f80b1eba857bda933c5936511b1d2b9a519c770b1a2f31360774232e03962ca47dea73ad5f4ef21bcd6530d2c123662
diff --git a/x11-misc/tint2/files/0.12.3-no-hardcode-update-icon-cache.patch b/x11-misc/tint2/files/0.12.3-no-hardcode-update-icon-cache.patch
new file mode 100644
index 000000000000..f923e0651737
--- /dev/null
+++ b/x11-misc/tint2/files/0.12.3-no-hardcode-update-icon-cache.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 155672e2245a..a4b6dc0c7eda 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -176,7 +176,6 @@ set_target_properties( tint2 PROPERTIES LINK_FLAGS "-pthread -fno-strict-aliasin
+ install( TARGETS tint2 DESTINATION bin )
+ install( FILES tint2.svg DESTINATION ${DATADIR}/icons/hicolor/scalable/apps )
+ install( FILES tint2.desktop DESTINATION ${DATADIR}/applications )
+-install( CODE "execute_process(COMMAND gtk-update-icon-cache -f -t ${DATADIR}/icons/hicolor WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX})" )
+ install( FILES sample/tint2rc DESTINATION ${SYSCONFDIR}/xdg/tint2 )
+ install( FILES default_icon.png DESTINATION ${DATADIR}/tint2 )
+ install( FILES AUTHORS ChangeLog README.md DESTINATION ${DOCDIR} )
+diff --git a/src/tint2conf/CMakeLists.txt b/src/tint2conf/CMakeLists.txt
+index e8c6db38fe20..f844c24371e7 100644
+--- a/src/tint2conf/CMakeLists.txt
++++ b/src/tint2conf/CMakeLists.txt
+@@ -71,4 +71,3 @@ add_subdirectory(po)
+ install( TARGETS tint2conf DESTINATION bin )
+ install( FILES tint2conf.svg DESTINATION ${DATADIR}/icons/hicolor/scalable/apps )
+ install( FILES tint2conf.desktop DESTINATION ${DATADIR}/applications )
+-install( CODE "execute_process(COMMAND gtk-update-icon-cache -f -t ${DATADIR}/icons/hicolor WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX})" )
diff --git a/x11-misc/tint2/tint2-0.12.3.ebuild b/x11-misc/tint2/tint2-0.12.3.ebuild
new file mode 100644
index 000000000000..c2415d390047
--- /dev/null
+++ b/x11-misc/tint2/tint2-0.12.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="tint2 is a lightweight panel/taskbar for Linux."
+HOMEPAGE="https://gitlab.com/o9000/tint2"
+SRC_URI="https://gitlab.com/o9000/${PN}/repository/archive.tar.gz?ref=v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="battery examples svg startup-notification tint2conf"
+
+DEPEND="
+ dev-libs/glib:2
+ svg? ( gnome-base/librsvg:2 )
+ >=media-libs/imlib2-1.4.2[X]
+ x11-libs/cairo
+ x11-libs/pango[X]
+ tint2conf? ( x11-libs/gtk+:2 )
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXrender
+ startup-notification? ( x11-libs/startup-notification )
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+PATCHES=( "${FILESDIR}/${PV}-no-hardcode-update-icon-cache.patch" )
+
+src_unpack() {
+ default
+ # Chop off the SHA1 gitlab's automated tarballs inject
+ mv "${PN}-v${PV}-"* "${PN}-v${PV}"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable battery BATTERY)
+ $(cmake-utils_use_enable examples EXAMPLES)
+ $(cmake-utils_use_enable tint2conf TINT2CONF)
+ $(cmake-utils_use_enable startup-notification SN)
+ $(cmake-utils_use_enable svg RSVG)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}