summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/tinymount
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/tinymount')
-rw-r--r--x11-misc/tinymount/Manifest1
-rw-r--r--x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch15
-rw-r--r--x11-misc/tinymount/metadata.xml19
-rw-r--r--x11-misc/tinymount/tinymount-0.2.8.ebuild57
4 files changed, 92 insertions, 0 deletions
diff --git a/x11-misc/tinymount/Manifest b/x11-misc/tinymount/Manifest
new file mode 100644
index 000000000000..88116742fcf7
--- /dev/null
+++ b/x11-misc/tinymount/Manifest
@@ -0,0 +1 @@
+DIST tinymount-0.2.8.tar.gz 28176 SHA256 c3aae8e77d32818cbb52a186924bfd0b22fdf45e6e5c73bff56ea478c45fe9ba SHA512 22a958938ce4b4d34d6edd037594945e91d37499264d7907c79c220bd38243b9e4e7b422b00cacc0af991fac9e7d9022d932042df7a65ef9339f351e9b94c758 WHIRLPOOL bbe0e3a5e7b8b595b0c870e0c68fb99bd2852ada2c5f246d5e3efca7689c57765e6f1f1bb1f524ef6367aa26a3b48c4f3468966f21f7808ba108ce28e3d4cac0
diff --git a/x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch b/x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch
new file mode 100644
index 000000000000..9032d3a3eb5a
--- /dev/null
+++ b/x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch
@@ -0,0 +1,15 @@
+# Don't build with libnotify unconditionally
+# bug #442048
+diff --git a/src/src.pro b/src/src.pro
+index 6a676cd..6b8c2f1 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -63,8 +63,6 @@ RESOURCES += tinymount.qrc
+
+ TRANSLATIONS = translations/tinymount_ru.ts
+
+-CONFIG += with_libnotify
+-
+ with_libnotify {
+ DEFINES += WITH_LIBNOTIFY
+ CONFIG += link_pkgconfig
diff --git a/x11-misc/tinymount/metadata.xml b/x11-misc/tinymount/metadata.xml
new file mode 100644
index 000000000000..102f7269c2c8
--- /dev/null
+++ b/x11-misc/tinymount/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>desktop-misc</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>limanski@narod.ru</email>
+ <name>Mike Limansky</name>
+ <description>Both upstream and ebuild author</description>
+ </maintainer>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">limansky/tinymount</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/tinymount/tinymount-0.2.8.ebuild b/x11-misc/tinymount/tinymount-0.2.8.ebuild
new file mode 100644
index 000000000000..0bad1c60fcde
--- /dev/null
+++ b/x11-misc/tinymount/tinymount-0.2.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="ru uk"
+inherit l10n qt4-r2
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI=("https://github.com/limansky/${PN}.git")
+ inherit git-r3
+else
+ SRC_URI="https://github.com/limansky/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple graphical utility for disk mounting"
+HOMEPAGE="https://github.com/limansky/tinymount"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug libnotify"
+
+COMMON_DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks:0"
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ remove_locale() {
+ sed -i -e "/translations\/${PN}_${1}.ts/d" src/src.pro || die
+ }
+
+ # Check for locales added/removed from previous version
+ l10n_find_plocales_changes src/translations "${PN}_" .ts
+
+ # Prevent disabled locales from being built
+ l10n_for_each_disabled_locale_do remove_locale
+
+ # Bug 441986
+ sed -i -e 's|-Werror||g' src/src.pro || die
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 \
+ PREFIX="${EPREFIX}/usr" \
+ $(use libnotify && echo CONFIG+=with_libnotify)
+}