summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xcb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xcb')
-rw-r--r--x11-misc/xcb/Manifest1
-rw-r--r--x11-misc/xcb/metadata.xml5
-rw-r--r--x11-misc/xcb/xcb-2.4-r1.ebuild52
-rw-r--r--x11-misc/xcb/xcb-2.4.ebuild49
4 files changed, 107 insertions, 0 deletions
diff --git a/x11-misc/xcb/Manifest b/x11-misc/xcb/Manifest
new file mode 100644
index 000000000000..807c05686b6e
--- /dev/null
+++ b/x11-misc/xcb/Manifest
@@ -0,0 +1 @@
+DIST xcb-2.4.tar.gz 19830 SHA256 21f25d05907fa3c8393b21474e81f4043af43fb087265f1753a5d57d068bc295
diff --git a/x11-misc/xcb/metadata.xml b/x11-misc/xcb/metadata.xml
new file mode 100644
index 000000000000..731225048652
--- /dev/null
+++ b/x11-misc/xcb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xcb/xcb-2.4-r1.ebuild b/x11-misc/xcb/xcb-2.4-r1.ebuild
new file mode 100644
index 000000000000..16165c63407f
--- /dev/null
+++ b/x11-misc/xcb/xcb-2.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Marc Lehmann's improved X Cut Buffers"
+HOMEPAGE="http://oldhome.schmorp.de/marc/xcb.html"
+SRC_URI="http://oldhome.schmorp.de/marc/data/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc x86"
+IUSE="motif"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ motif? ( >=x11-libs/motif-2.3:0 )"
+
+src_compile() {
+ local gui libs
+
+ if use motif; then
+ gui="-DMOTIF"
+ libs="-lXm -lXt -lX11"
+ else
+ gui="-DATHENA"
+ libs="-lXaw -lXt -lXext -lX11"
+ fi
+
+ emake -f Makefile.std xcb Xcb.ad \
+ CC=$(tc-getCC) \
+ CPP=$(tc-getCPP) \
+ CFLAGS="${CFLAGS} ${gui}" \
+ GUI="${gui}" \
+ LIBS="${libs}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin xcb || die "dobin failed"
+ newman xcb.man xcb.1
+ insinto /usr/share/X11/app-defaults
+ newins Xcb.ad Xcb || die "newins failed"
+}
diff --git a/x11-misc/xcb/xcb-2.4.ebuild b/x11-misc/xcb/xcb-2.4.ebuild
new file mode 100644
index 000000000000..f3fdf2a246c6
--- /dev/null
+++ b/x11-misc/xcb/xcb-2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Marc Lehmann's improved X Cut Buffers"
+HOMEPAGE="http://oldhome.schmorp.de/marc/xcb.html"
+SRC_URI="http://oldhome.schmorp.de/marc/data/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc x86"
+IUSE="motif"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ motif? ( >=x11-libs/motif-2.3:0 )"
+
+src_compile() {
+ local gui libs
+
+ if use motif; then
+ gui="-DMOTIF"
+ libs="-lXm -lXt -lX11"
+ else
+ gui="-DATHENA"
+ libs="-lXaw -lXt -lXext -lX11"
+ fi
+
+ tc-export CC
+ emake -f Makefile.std xcb Xcb.ad \
+ CFLAGS="${CFLAGS} ${gui}" \
+ GUI="${gui}" \
+ LIBS="${libs}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin xcb || die "dobin failed"
+ newman xcb.man xcb.1
+ insinto /usr/share/X11/app-defaults
+ newins Xcb.ad Xcb || die "newins failed"
+}