summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 23:37:28 +0100
committerSam James <sam@gentoo.org>2021-04-07 23:39:26 +0100
commit01b4a16129343d73efc27c98aa0dbd28eefae2a5 (patch)
tree60e57f8f1a1da4d0235bf3d49c134ce00868e8e7 /x11-misc/xdg-utils/xdg-utils-1.1.3-r3.ebuild
parentdev-python/websocket-client: Undo accidental revert to ~arch (diff)
downloadgentoo-01b4a16129343d73efc27c98aa0dbd28eefae2a5.tar.gz
gentoo-01b4a16129343d73efc27c98aa0dbd28eefae2a5.tar.bz2
gentoo-01b4a16129343d73efc27c98aa0dbd28eefae2a5.zip
x11-misc/xdg-utils: loosen xmlto requirement again
Apologies for the noise. Dropping the newer xmlto bound while we sort out the issues there (should be OK now), but erring on the side of caution. (We've dropped the new xmlto changes back to ~arch). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/xdg-utils/xdg-utils-1.1.3-r3.ebuild')
-rw-r--r--x11-misc/xdg-utils/xdg-utils-1.1.3-r3.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/xdg-utils/xdg-utils-1.1.3-r3.ebuild b/x11-misc/xdg-utils/xdg-utils-1.1.3-r3.ebuild
new file mode 100644
index 000000000000..7409d5982806
--- /dev/null
+++ b/x11-misc/xdg-utils/xdg-utils-1.1.3-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Portland utils for cross-platform/cross-toolkit/cross-desktop interoperability"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xdg-utils/"
+#SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+#SRC_URI="https://people.freedesktop.org/~rdieter/${PN}/${MY_P}.tar.gz
+# https://dev.gentoo.org/~ssuominen/${P}-patchset-1.tar.xz"
+SRC_URI="https://portland.freedesktop.org/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-util/desktop-file-utils
+ dev-perl/File-MimeInfo
+ dev-perl/Net-DBus
+ dev-perl/X11-Protocol
+ sys-apps/dbus
+ x11-misc/shared-mime-info
+ x11-apps/xprop
+ x11-apps/xset
+"
+DEPEND="
+ >=app-text/xmlto-0.0.28-r3[text(+)]
+ virtual/awk
+"
+
+DOCS=( ChangeLog README RELEASE_NOTES TODO )
+
+RESTRICT="test" # Disabled because of sandbox violation(s)
+
+PATCHES=(
+ "${FILESDIR}"/xdg-utils-1.1.3-xdg-open-pcmanfm.patch
+)
+
+#S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ # If you choose to do git snapshot instead of patchset, you need to remember
+ # to run `autoconf` in ./ and `make scripts-clean` in ./scripts/ to refresh
+ # all the files
+ if [[ -d "${WORKDIR}/patch" ]]; then
+ eapply "${WORKDIR}/patch"
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_path_XMLTO="$(type -P xmlto) --skip-validation" #502166
+ default
+}
+
+src_install() {
+ default
+
+ newdoc scripts/xsl/README README.xsl
+ use doc && dodoc -r scripts/html
+
+ # Install default XDG_DATA_DIRS, bug #264647
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/local/share\" > 30xdg-data-local
+ echo 'COLON_SEPARATED="XDG_DATA_DIRS XDG_CONFIG_DIRS"' >> 30xdg-data-local
+ doenvd 30xdg-data-local
+
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/share\" > 90xdg-data-base
+ echo XDG_CONFIG_DIRS=\"${EPREFIX}/etc/xdg\" >> 90xdg-data-base
+ doenvd 90xdg-data-base
+}
+
+pkg_postinst() {
+ [[ -x $(type -P gtk-update-icon-cache) ]] \
+ || elog "Install dev-util/gtk-update-icon-cache for the gtk-update-icon-cache command."
+}