summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-06 02:26:19 +0000
committerSam James <sam@gentoo.org>2024-02-06 02:26:19 +0000
commitb726baaa06035849738435866c21f44d207f832c (patch)
tree4185438497704a68e8388d737c033666691a7ac2 /x11-misc/xdg-utils
parentsys-fs/zfs-kmod: backport autotrim CPU fix (diff)
downloadgentoo-b726baaa06035849738435866c21f44d207f832c.tar.gz
gentoo-b726baaa06035849738435866c21f44d207f832c.tar.bz2
gentoo-b726baaa06035849738435866c21f44d207f832c.zip
x11-misc/xdg-utils: add 1.2.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/xdg-utils')
-rw-r--r--x11-misc/xdg-utils/Manifest1
-rw-r--r--x11-misc/xdg-utils/xdg-utils-1.2.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-misc/xdg-utils/Manifest b/x11-misc/xdg-utils/Manifest
index cce0e8371457..12b264770be3 100644
--- a/x11-misc/xdg-utils/Manifest
+++ b/x11-misc/xdg-utils/Manifest
@@ -2,3 +2,4 @@ DIST xdg-utils-1.1.3_p20200220-no-which.patch.xz 5576 BLAKE2B cf8c3111689c355add
DIST xdg-utils-1.1.3_p20210805.tar.bz2 287544 BLAKE2B ec3755e5e6f596c5787324ab254ba14938f35dda6df5a4ef88fb582c5df7704e706dee2f4362cc0597164cf2aeab5cf8f5f6db1b9d374355723e3d738e101264 SHA512 ec51e98e4c73ad7cb3c77051617a939c7956c7da6bcbbcda4e54121af247ce6978c8638c80bc644a49cfca14b18f06cb25747719bc20c97f7e60b9b4f3597a71
DIST xdg-utils-1.2.0_beta1_p20231203.tar.bz2 291213 BLAKE2B 65004e451f002175a1dd5c142f9be312e66b16917ea61e3e8a907c92c99aa7e8a0111951ef075830ac2b2a09e809778a91770c6021edd82174ff4eef2a72fca1 SHA512 a19750fa9b18dbad434134e7b336c622419a9e272d310e10cd711fca592ecd5b6ee4fe648222108ada463c18c103310d92b4ca209057ee0372414e9041f489de
DIST xdg-utils-v1.2.0.tar.bz2 293400 BLAKE2B 896678febecbb8dff8d272d0901b28692406fa11d97ab0c43c45d2097f18d95a38c44f4eacd7ce2b9e14bb52835009755d50232904958b57d260e8f9d84ce020 SHA512 6562d728c0eac50a650ed5917eab83259f340691d7e7b94e4a6c58f3068fd1b62cfabc38efd3e39a246001c689d2cb2f001cef93af8281e868a20a49282daf91
+DIST xdg-utils-v1.2.1.tar.bz2 293386 BLAKE2B 9d6ce4be8c27ad5b8d0ae55ad0d8b4457b59cb1bd260884ca5bfd2cb8ed7ed68a2f5a8db6d660ceabab59cbb9880fd4f1a26cb71a8f759ec40c2f9f95bbc8a05 SHA512 d5436449fec2f4db952239ee910bfda203955c8df8cb92379f182dc36f9c82b6ceb092ccbebfd02ed00eb7ef5f6895ef745baca67906ae7490e425db27b1dbfc
diff --git a/x11-misc/xdg-utils/xdg-utils-1.2.1.ebuild b/x11-misc/xdg-utils/xdg-utils-1.2.1.ebuild
new file mode 100644
index 000000000000..110d275dac9b
--- /dev/null
+++ b/x11-misc/xdg-utils/xdg-utils-1.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Portland utils for cross-platform/cross-toolkit/cross-desktop interoperability"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xdg-utils/"
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="d4f00e1d803038af4f245949d8c747a384117852"
+ SRC_URI="https://gitlab.freedesktop.org/xdg/xdg-utils/-/archive/${MY_COMMIT}/${P}.tar.bz2"
+ S="${WORKDIR}"/xdg-utils-${MY_COMMIT}
+else
+ SRC_URI="https://gitlab.freedesktop.org/xdg/xdg-utils/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}"/${PN}-v${PV}
+fi
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus doc gnome"
+REQUIRED_USE="gnome? ( dbus )"
+
+RDEPEND="
+ dev-util/desktop-file-utils
+ dev-perl/File-MimeInfo
+ dbus? (
+ sys-apps/dbus
+ gnome? (
+ dev-perl/Net-DBus
+ dev-perl/X11-Protocol
+ )
+ )
+ x11-misc/shared-mime-info
+ x11-apps/xprop
+ x11-apps/xset
+"
+BDEPEND="
+ >=app-text/xmlto-0.0.28-r3[text(+)]
+ app-alternatives/awk
+"
+
+# Tests run random system programs, including interactive programs
+# that block forever
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *_p* ]] ; then
+ # If you choose to do git snapshot instead of patchset, you need to remember
+ # to run `autoconf` in ./ and `make scripts-clean` in ./scripts/ to refresh
+ # all the files
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ export ac_cv_path_XMLTO="$(type -P xmlto) --skip-validation" #502166
+ default
+ emake -C scripts scripts-clean
+}
+
+src_install() {
+ default
+
+ dodoc RELEASE_NOTES
+
+ newdoc scripts/xsl/README README.xsl
+ use doc && dodoc -r scripts/html
+
+ # Install default XDG_DATA_DIRS, bug #264647
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/local/share\" > 30xdg-data-local || die
+ echo 'COLON_SEPARATED="XDG_DATA_DIRS XDG_CONFIG_DIRS"' >> 30xdg-data-local || die
+ doenvd 30xdg-data-local
+
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/share\" > 90xdg-data-base || die
+ echo XDG_CONFIG_DIRS=\"${EPREFIX}/etc/xdg\" >> 90xdg-data-base || die
+ doenvd 90xdg-data-base
+}
+
+pkg_postinst() {
+ [[ -x $(type -P gtk-update-icon-cache) ]] \
+ || elog "Install dev-util/gtk-update-icon-cache for the gtk-update-icon-cache command."
+}