summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-16 00:32:01 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-16 00:42:39 -0500
commit090c0263eb1bbecc67b2a0126a1b844add49b02b (patch)
treef076464d1753a0892e3e3bf61c94a9147bc39e62 /x11-misc/xdo/xdo-0.5.ebuild
parentgames-fps/sauerbraten: version bump (diff)
downloadgentoo-090c0263eb1bbecc67b2a0126a1b844add49b02b.tar.gz
gentoo-090c0263eb1bbecc67b2a0126a1b844add49b02b.tar.bz2
gentoo-090c0263eb1bbecc67b2a0126a1b844add49b02b.zip
x11-misc/xdo: version bump to 0.5
Diffstat (limited to 'x11-misc/xdo/xdo-0.5.ebuild')
-rw-r--r--x11-misc/xdo/xdo-0.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/xdo/xdo-0.5.ebuild b/x11-misc/xdo/xdo-0.5.ebuild
new file mode 100644
index 000000000000..880c0bf7478f
--- /dev/null
+++ b/x11-misc/xdo/xdo-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Small X utility to perform elementary actions on windows"
+HOMEPAGE="https://github.com/baskerville/xdo/"
+SRC_URI="https://github.com/baskerville/xdo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libxcb
+ x11-libs/xcb-util-wm"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}