summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-07-15 16:27:47 +0300
committerMichael Palimaka <kensington@gentoo.org>2017-07-16 00:10:33 +1000
commit6057b34f14dccaba42205a76aa0d581eb3158bc2 (patch)
tree88b07762db6187690bdc3e035612ea8fba8a187a /x11-misc/xembedsniproxy/files
parentdev-python/restkit: keyword ~arm64 (diff)
downloadgentoo-6057b34f14dccaba42205a76aa0d581eb3158bc2.tar.gz
gentoo-6057b34f14dccaba42205a76aa0d581eb3158bc2.tar.bz2
gentoo-6057b34f14dccaba42205a76aa0d581eb3158bc2.zip
x11-misc/xembedsniproxy: new ebuild
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-misc/xembedsniproxy/files')
-rw-r--r--x11-misc/xembedsniproxy/files/xembedsniproxy-5.10.3-Standalone-build.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/xembedsniproxy/files/xembedsniproxy-5.10.3-Standalone-build.patch b/x11-misc/xembedsniproxy/files/xembedsniproxy-5.10.3-Standalone-build.patch
new file mode 100644
index 000000000000..8ccd2ad0bd59
--- /dev/null
+++ b/x11-misc/xembedsniproxy/files/xembedsniproxy-5.10.3-Standalone-build.patch
@@ -0,0 +1,47 @@
+From c19bc38c85ca14df7034ef4c97b0681de1c1a6a2 Mon Sep 17 00:00:00 2001
+From: Mykyta Holubakha <hilobakho@gmail.com>
+Date: Sat, 15 Jul 2017 15:52:30 +0300
+Subject: [PATCH] Standalone xembedsniproxy build
+
+---
+ xembed-sni-proxy/CMakeLists.txt | 27 +++++++++++++++++++++++++++
+ 1 file changed, 27 insertions(+)
+
+diff --git a/xembed-sni-proxy/CMakeLists.txt b/xembed-sni-proxy/CMakeLists.txt
+index c2f67ac6..e74c7437 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,3 +1,30 @@
++cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
++
++project(plasma-workspace)
++
++set(QT_MIN_VERSION "5.7.0")
++set(KF5_MIN_VERSION "5.34.0")
++
++find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
++ Core
++ DBus
++ X11Extras
++)
++
++
++find_package(ECM 1.8.0 REQUIRED NO_MODULE)
++set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
++
++include(KDEInstallDirs)
++include(KDECMakeSettings)
++include(KDECompilerSettings NO_POLICY_SCOPE)
++include(FeatureSummary)
++include(ECMOptionalAddSubdirectory)
++include(ECMQtDeclareLoggingCategory)
++
++find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS WindowSystem)
++find_package(X11)
++
+ add_definitions(-DQT_NO_CAST_TO_ASCII
+ -DQT_NO_CAST_FROM_ASCII
+ -DQT_NO_URL_CAST_FROM_STRING
+--
+2.13.1
+