summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-31 12:24:50 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-31 12:25:47 +0200
commit3e77cee4b328f72aa81b625eddb84cedd5bd87b3 (patch)
treea8193d3ee15006799abf811f48515686ef1b1c83 /x11-misc/xfe/xfe-1.42.ebuild
parentgnome-base/gnome-control-center: mouse panel needs a concrete set of plugins ... (diff)
downloadgentoo-3e77cee4b328f72aa81b625eddb84cedd5bd87b3.tar.gz
gentoo-3e77cee4b328f72aa81b625eddb84cedd5bd87b3.tar.bz2
gentoo-3e77cee4b328f72aa81b625eddb84cedd5bd87b3.zip
x11-misc/xfe: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/xfe/xfe-1.42.ebuild')
-rw-r--r--x11-misc/xfe/xfe-1.42.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/xfe/xfe-1.42.ebuild b/x11-misc/xfe/xfe-1.42.ebuild
new file mode 100644
index 000000000000..aa618eda304e
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.42.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PLOCALES="
+ bs ca cs da de el es_AR es_CO es fr hu it ja nl no pl pt_BR pt_PT ru sv tr
+ zh_CN zh_TW
+"
+inherit autotools eutils l10n
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[png,truetype]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+
+ sed -i \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ --enable-minimalflags
+}