summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Eisele <kernlpanic@dennis-eisele.de>2022-05-14 16:43:06 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-05-24 10:13:00 +0300
commit32313db1e2c614c79ba9a0aa18edaa59f48b1992 (patch)
tree511b9b5678b1254b6b4b14bdcc5faf0d43c7bd3d /x11-misc/xfe
parentdev-python/pytest-skip-markers: Fix dependencies, py3.11 (diff)
downloadgentoo-32313db1e2c614c79ba9a0aa18edaa59f48b1992.tar.gz
gentoo-32313db1e2c614c79ba9a0aa18edaa59f48b1992.tar.bz2
gentoo-32313db1e2c614c79ba9a0aa18edaa59f48b1992.zip
x11-misc/xfe: bump to version 1.44
Closes: https://bugs.gentoo.org/836834 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Dennis Eisele <kernlpanic@dennis-eisele.de> Closes: https://github.com/gentoo/gentoo/pull/25263 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/xfe')
-rw-r--r--x11-misc/xfe/Manifest1
-rw-r--r--x11-misc/xfe/xfe-1.44.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
index 071ab3b972ab..4366ba8b9552 100644
--- a/x11-misc/xfe/Manifest
+++ b/x11-misc/xfe/Manifest
@@ -1 +1,2 @@
DIST xfe-1.43.2.tar.gz 2834576 BLAKE2B 5ac7ebf229febb75a99e4829a38a3675d6674ec6eced13dc5be70d2b68ce88f6394621dffec2d8359e72da7eace582883b72491e90597ab4a8925685cb577fcb SHA512 ad7b450d0828747f801219c23824b0751fc2a7f0eea791369c4adb3090ffe1279056fa8804ef97b25a2f810e00d37357efc962dc9d4087c3d7cc5f8ffb37d51d
+DIST xfe-1.44.tar.xz 1444296 BLAKE2B 3ace2689adc2a4e2b24e44f8f416cad5e4904d38d2be7e275256714a707995368450e63c4cf2eee3f870be51c42f295a938ea6ecd159dd1a996aad53b5d119b3 SHA512 d02f0db46c5ca6e26cff447d7f11bbc5f03a9d28b8d492a783bb47f67431a022785d6f3b25013f82a6121a8675f86caf1a9154a7faa8186e05cf4de0bd2f1749
diff --git a/x11-misc/xfe/xfe-1.44.ebuild b/x11-misc/xfe/xfe-1.44.ebuild
new file mode 100644
index 000000000000..0f46f4222a52
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.44.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="
+ bs ca cs da de el es_AR es_CO es fr hu it ja nl no pl pt_BR pt_PT ru sv tr
+ zh_CN zh_TW
+"
+inherit plocale xdg-utils
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ x11-libs/fox:1.6[png,truetype]
+ media-libs/fontconfig
+ x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip || die <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ plocale_for_each_disabled_locale rm_locale
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ --enable-minimalflags
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}