summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <ck+gentoo@bl4ckb0x.de>2018-03-29 14:56:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-03-29 17:04:27 +0200
commit133aec6aa2e6b4226479d63e41231ec96f0b315a (patch)
tree5fc87497a824ef2ab3d5b391e234fabd43d3d8f5 /x11-misc/xflux-gui/xflux-gui-1.1.10.ebuild
parentapp-metrics/prometheus-mysqld_exporter: Rev bump (diff)
downloadgentoo-133aec6aa2e6b4226479d63e41231ec96f0b315a.tar.gz
gentoo-133aec6aa2e6b4226479d63e41231ec96f0b315a.tar.bz2
gentoo-133aec6aa2e6b4226479d63e41231ec96f0b315a.zip
x11-misc/xflux-gui: New package
Closes: https://bugs.gentoo.org/606130 Closes: https://github.com/gentoo/gentoo/pull/731
Diffstat (limited to 'x11-misc/xflux-gui/xflux-gui-1.1.10.ebuild')
-rw-r--r--x11-misc/xflux-gui/xflux-gui-1.1.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/xflux-gui/xflux-gui-1.1.10.ebuild b/x11-misc/xflux-gui/xflux-gui-1.1.10.ebuild
new file mode 100644
index 000000000000..b83597ea10c3
--- /dev/null
+++ b/x11-misc/xflux-gui/xflux-gui-1.1.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A GUI for f.lux"
+HOMEPAGE="https://justgetflux.com/"
+SRC_URI="https://github.com/xflux-gui/fluxgui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-libs/libappindicator:2[python,${PYTHON_USEDEP}]
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ gnome-base/libglade
+ x11-libs/libXxf86vm
+ x11-misc/xflux"
+
+S="${WORKDIR}/fluxgui-${PV}"
+
+pkg_postinst() {
+ # Update Gnome icon cache on install
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ # Update Gnome icon cache on uninstall
+ gnome2_icon_cache_update
+}