summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-07-21 12:22:06 +0200
committerJeroen Roovers <jer@gentoo.org>2020-07-21 12:30:27 +0200
commitc1a1f1ebc4cb70693c3c54e8fc9ca96aeaa6e12f (patch)
tree3580465a803899727c0c83127d7469075b2a2ece /x11-misc/xkbd/xkbd-999999.ebuild
parentx11-misc/xkbd: Version 0.8.18 (diff)
downloadgentoo-c1a1f1ebc4cb70693c3c54e8fc9ca96aeaa6e12f.tar.gz
gentoo-c1a1f1ebc4cb70693c3c54e8fc9ca96aeaa6e12f.tar.bz2
gentoo-c1a1f1ebc4cb70693c3c54e8fc9ca96aeaa6e12f.zip
x11-misc/xkbd: Add live ebuild
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xkbd/xkbd-999999.ebuild')
-rw-r--r--x11-misc/xkbd/xkbd-999999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/xkbd/xkbd-999999.ebuild b/x11-misc/xkbd/xkbd-999999.ebuild
new file mode 100644
index 000000000000..8d6139bf4019
--- /dev/null
+++ b/x11-misc/xkbd/xkbd-999999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic git-r3
+
+DESCRIPTION="onscreen soft keyboard for X11"
+HOMEPAGE="https://github.com/mahatma-kaganovich/xkbd"
+EGIT_REPO_URI="https://github.com/mahatma-kaganovich/xkbd"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +evdev +xft +xi +xpm +xrandr +xscreensaver"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXtst
+ evdev? ( dev-libs/libevdev )
+ xft? ( x11-libs/libXft )
+ xpm? ( x11-libs/libXpm )
+ xrandr? ( x11-libs/libXrandr )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+DOCS=( AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-999999-evdev.patch
+ "${FILESDIR}"/${PN}-999999-xft.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG
+ econf \
+ $(use_enable evdev) \
+ $(use_enable xft) \
+ $(use_enable xi) \
+ $(use_enable xpm) \
+ $(use_enable xrandr) \
+ $(use_enable xscreensaver ss) \
+ --disable-debug
+}