summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xmobar/xmobar-0.22.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xmobar/xmobar-0.22.1.ebuild')
-rw-r--r--x11-misc/xmobar/xmobar-0.22.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/x11-misc/xmobar/xmobar-0.22.1.ebuild b/x11-misc/xmobar/xmobar-0.22.1.ebuild
new file mode 100644
index 000000000000..26b8e7ef17e4
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.22.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -all_extensions,+with_threaded,+with_utf8,with_iwlib:wifi,with_alsa:alsa,with_xft:xft,with_datezone:timezone,with_dbus:dbus,with_mpd:mpd,with_inotify:inotify,with_mpris:mpris,with_xpm:xpm
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://xmobar.org"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus inotify mpd mpris timezone wifi xft xpm"
+
+RDEPEND="x11-libs/libXrandr
+ wifi? ( net-wireless/wireless-tools )
+ xpm? ( x11-libs/libXpm )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ >=dev-haskell/http-4000
+ >=dev-haskell/mtl-2.1 <dev-haskell/mtl-2.3
+ >=dev-haskell/parsec-3.1 <dev-haskell/parsec-3.2
+ dev-haskell/regex-compat
+ >=dev-haskell/stm-2.3 <dev-haskell/stm-2.5
+ dev-haskell/transformers
+ >=dev-haskell/utf8-string-0.3 <dev-haskell/utf8-string-0.4
+ >=dev-haskell/x11-1.6.1
+ >=dev-lang/ghc-7.4.1
+ alsa? ( >=dev-haskell/alsa-core-0.5 <dev-haskell/alsa-core-0.6
+ >=dev-haskell/alsa-mixer-0.2 <dev-haskell/alsa-mixer-0.3 )
+ dbus? ( >=dev-haskell/dbus-0.10 )
+ inotify? ( >=dev-haskell/hinotify-0.3 <dev-haskell/hinotify-0.4 )
+ mpd? ( >=dev-haskell/libmpd-0.9 <dev-haskell/libmpd-0.10 )
+ mpris? ( >=dev-haskell/dbus-0.10 )
+ timezone? ( >=dev-haskell/timezone-olson-0.1 <dev-haskell/timezone-olson-0.2
+ >=dev-haskell/timezone-series-0.1 <dev-haskell/timezone-series-0.2 )
+ xft? ( >=dev-haskell/x11-xft-0.2 <dev-haskell/x11-xft-0.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-all_extensions \
+ $(cabal_flag alsa with_alsa) \
+ $(cabal_flag timezone with_datezone) \
+ $(cabal_flag dbus with_dbus) \
+ $(cabal_flag inotify with_inotify) \
+ $(cabal_flag wifi with_iwlib) \
+ $(cabal_flag mpd with_mpd) \
+ $(cabal_flag mpris with_mpris) \
+ --flag=with_threaded \
+ --flag=with_utf8 \
+ $(cabal_flag xft with_xft) \
+ $(cabal_flag xpm with_xpm)
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc samples/xmobar.config readme.md news.md
+}