summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xrestop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xrestop')
-rw-r--r--x11-misc/xrestop/Manifest1
-rw-r--r--x11-misc/xrestop/files/xrestop-0.4-tinfo.patch10
-rw-r--r--x11-misc/xrestop/metadata.xml5
-rw-r--r--x11-misc/xrestop/xrestop-0.4.ebuild32
4 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/xrestop/Manifest b/x11-misc/xrestop/Manifest
new file mode 100644
index 000000000000..f0b6d926a85b
--- /dev/null
+++ b/x11-misc/xrestop/Manifest
@@ -0,0 +1 @@
+DIST xrestop-0.4.tar.gz 92308 SHA256 67c2fc94a7ecedbaae0d1837e82e93d1d98f4a6d759828860e552119af3ce257 SHA512 eb7bf2f3ab7b73708c96d56fd466cb362d711242dd46992fa3e693af2d26995e9baa91075eb445ef227e1342deec5e0e22b37139e80399e4051c9f5cad8fd9b6 WHIRLPOOL 87f3679b529728d4dc16fb5b93e0ef19908c9304bd540d8bc8b7b813da5d43668878592f056c8f849a21b7b7f6ab0c72503e9b0456fec3a1234894bf302b8c09
diff --git a/x11-misc/xrestop/files/xrestop-0.4-tinfo.patch b/x11-misc/xrestop/files/xrestop-0.4-tinfo.patch
new file mode 100644
index 000000000000..ef2de121e839
--- /dev/null
+++ b/x11-misc/xrestop/files/xrestop-0.4-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -65,6 +65,7 @@
+
+ # check for ncurses, fall back to curses
+ AC_CHECK_LIB([ncurses], [initscr],,AC_CHECK_LIB([curses], [initscr]))
++AC_SEARCH_LIBS([stdscr], [tinfo])
+
+ if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -fno-strict-aliasing"
diff --git a/x11-misc/xrestop/metadata.xml b/x11-misc/xrestop/metadata.xml
new file mode 100644
index 000000000000..2518313f5241
--- /dev/null
+++ b/x11-misc/xrestop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xrestop/xrestop-0.4.ebuild b/x11-misc/xrestop/xrestop-0.4.ebuild
new file mode 100644
index 000000000000..1041aaba4afb
--- /dev/null
+++ b/x11-misc/xrestop/xrestop-0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="'Top' like statistics of X11 client's server side resource usage"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/xrestop"
+SRC_URI="http://projects.o-hand.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86 ~x86-fbsd"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )